10mm Added to Z-height When Creating Gcode in CC?!

I am a new CNC-er and just bought a Shapeoko 4 with the new bitsetter.

I am milling 5 contoured cut pumpkins on ~0.375" (5mm) plywood. Everything looks fine in CC settings, but when I create the gcode, it loads in Carbide Motion with a z-height of 15mm?!?

I have tried both Imperial and Metric settings, with and without the bitsetter active; and it loads the same.

Am I missing something?

Five Pumpkins.c2d (107.2 KB)
Five Pumpkins.nc (387.7 KB)

You have a stock thickness of 4.762mm and a safety/retract height of 12.7mm — shouldn’t this be 17.462mm?

Could you post a screen grab of what you mean?


It would seem that Carbide Motion is getting this calculation of the total extent of the machine travel wrong — should be 17.4625mm.