2 Problems with Using Jogging and Zeroing

I have 2 problems with using the jog and zeroing functions of Carbide Motion. These problems have been there for every version of Carbide Motion that I have used.

The first is that if I jog to a position, and then set the zero on one of the axes (say “X”). Then when I drop out of the zeroing function, I can no longer jog using the arrow and page keys. I then have to click on the icons on the screen. That is annoying, but I can deal with.

The second one is more serious. When I set the Z-axis zero it never takes the first time. What I do now is set X, then Y, then Z. Then I close Carbide Motion, open it, and double check that the zeros have taken. The Z axis never takes. I then redo the Z, and I’m good to go. Before I started doing this, the tool always crashed when it moved to the zero starting point.

I am running Carbide Motion on a PC under Windows 7. I think I have the latest version, but this has happened on all of the versions that I have used.

Any thoughts on what is going wrong?


Interesting, are you homing the machine before you set the 0? Are you using the latest 4.07?

I am definitely homing the machine before I zero. It does it automatically when I enter Jog mode, and I don’t know how to avoid it even if I wanted to.

I’ll check the version when I get home. That said, both problems have occurred with all of the versions of Carbide Motion I have tried.

Could this be a machine version problem (that is, a problem with the Nomad’s software version rather than the version of Carbide Motion)? If so, how do you check the machine software version?



I checked the version of Carbide Motion, and it is 3.0.366. I’m not sure what 4.07 refers to. This is a Nomad machine I’m working with.


4.07 is the latest motion beta, but requires GRBL 1.1 on your machine.

Most odd behavior… I presume you’re running a mouse as a pointer?

Well it is a laptop, and I’m using a trackpad as a pointer.

The machine is running GRBL 0.9. Where do you get the updated machine operating system? Also, how do you get the beta version of Motion?



Just checking, but you are not confusing Z+6mm as an incorrect Z position?

I’m not sure what the Z+6mm is. What happens is I put in a new Z axis value in the zero window, go back to the jogging window, and the Z value is unchanged.


Z+6mm is a Rapid Position command (button).

I can’t say that I’ve tried to set zero by “put in/entering” a value of zero (presumably?) based on what you’ve described. Zero’ing is done via button click for one or all axes? Did you really mean that you’ve clicked the zero button?

1 Like

I’ve done both. Moved the tool to a position (edge finding), and entered the radius of the edge finder (then hitting enter), and moved the tool to a position and enter “0”. This always works for X and Y, and it never works for Z. At least when I do Z last, which I do most of the time since I set zero for X and Y with an edge finder, and Z with the actual tool.

I’ve been bit by this more than once. You have to click in another of the zero windows, or press enter. Looks like it should take by just entering the value then clicking “done” but it doesn’t. You need to click in another entry box or press enter. Goofy, I agree.


I get your workflow requirements by touching off against the work and/or entering an offset based on tool diameter. Enter Key and/or focusing to another control as Mike suggests sounds like that might be what’s going in (at least it sounds reasonable to me). Edit and focus are the means by which several UI’s determine dirty controls and/or new data has been entered.