A $2000 paperweight

Just put machine together and had a few test cuts and now when I start it up and connect to carbide motion it moves to back and just wants to keep going having to shut machine down to get the grinding to stop. All wires are plugged in now I’m wishing I would of went with a onefinity or kept my xcarve

Hello Gary,

Did you contact support@carbide3d.com ?

It may just be a problem in the wiring/setup of the switches (if this occurs during machine initialization?) or possibly a wrong setup/zeroing procedure if this happens while launching a job.

If you tell us more about your setup and job you are trying to run, we should be able to sort it out (here, or support will do it with you)

2 Likes

It is the y switch, swapped x and y switches and it stops. Is there a way to disable this initialization function where I can manually set zero to get some jobs done?

You should really troubleshoot this Y switch problem. But if you must, you should be able to unlock the machine / bypass homing by sending $X to the controller using the MDI tab in CM. It’s been a while since I last did that, I can’t guarantee CM will like it.

How else do I diagnose the switch? If I swap the x and y on board when x gets to home it stops the y, the y switch is obviously bad isn’t it?

Carbide Motion requires homing on machines which have Grbl 1.1

For the Pro see: Sending Config Settings for Shapeoko Pro - YouTube

There is a basic page on troubleshooting the homing switches at: Home Switch Troubleshooting - Carbide 3D

There is also a Carbide 3D Answer video: Basic Shapeoko Limit Switch Troubleshooting - YouTube

For the new inductive homing switches: Troubleshooting: Proximity Switch Troubleshooting - YouTube and Adjusting: Adjusting the Proximity Switches - YouTube

If you continue to have difficulties please contact us at support@carbide3d.com letting us know that you have seen the above links so that we don’t resend them.

If you had a few test cuts and they were successful I would check to see if a proximity switch came loose and fell out of adjustment

2 Likes

With the machine power OFF, SLOWLY move the X, Y and Z away from the Home location. Then connect to the Machine (Carbide Motion) but DO NOT you hit the home (Initialize) button. Place a piece of metal VERY close to the Homing (proximity) Switch. The small (and dim) LED should light up. Do that to all 3 switches. I use the wrench from the router…

Note, The switch could be GOOD but not CLOSE enough to the metal that it was meant to home (locate) to. Meaning it might need to be moved closer OR you need to remove whatever is stopping from getting close enough.

As you use the machine, something a small piece of debris can land in this location and needs to be cleaned off before homing can continue…quite normal…(please relax…its a GREAT machine and GREAT team).

5.5 Year Owner

1 Like

Yeah the y proximity switch does not light up, it is plugged in and if swapped with x it still does not light up. But x will light up if plugged into y spot on board.

Check the wiring in the connector. Anything loose? How about the order of the wires? Same as X?

1 Like

when I first received my Pro the Y limit switch was too high and the X axis carriage would bump into it as it tried to move into maximum Y position.
I had to loosen and lower the switch by a few mm so that the carriage could move over top of it and zero correctly.

2 Likes

Sounds like a dead switch.

These things are pretty simple to test. Put some metal next it and it should light up (metal that a magnet sticks to).

Maybe check that the three wires on the bad switch are the same colour and position as the ones on the good switch. If not, you can swap them around if you choose too. You need to depress the tiny tongue that prevents them from being unslotted.

1 Like

Check the connectors and make sure the wires are seated properly. If it worked before it sounds like a loose wire. Also jiggle the harness and see if the sensor lights up. If it does it’s either a broken wire or a wire backed out of the connector.

1 Like