A better Fusion360 - GRBL PostProcessor

If you are using Fusion360 for your designs, and millthem on a GRBL based machine, then take a look at


I took the existing GRBL PostProcessor and cleaned it up to make it better.
If you have a Makita RT0700 or Dewalt 611 or similar, it also translates the spindle speeds to a dial setting.
If you make mistakes in your design, the post-processor will alert you and recommmend how to solve them.

It’s free, documented, feedback & test-results are welcome.


Very interesting! I like the speed conversion for the router dial. Nice touch! I’ve just built my XXL and the dial setting was something I knew I had to figure out.

I’ll have a look this evening!

DWP611 speeds are also approximated on the Speeds 'n Feeds page:

@Strooom I love Fusion 360, and would love a better post processor. I downloaded the cps file from GitHub and tried using it. I have nothing in the properties box in the lower right corner of the post processing dialog box.

Also, when posting I get the following:

Error: Failed to evaluate post configuration.
Code page changed to ‘1252 (ANSI - Latin I)’
Start time: Friday, September 23, 2016 3:34:32 PM
Error(C:\Users\sdcon\AppData\Local\Autodesk\webdeploy\production\8230b364be98230257f730ec9822611826c56dfb\Applications\CAM360\Data\Posts\OpenbuildsGRBL.cps:5): SyntaxError: missing = in XML attribute
Failed while processing global script.
Error: Syntax error: Missing end of literal at line 139.

What am I doing wrong? I just copied the cps file into the default configuration folder and tried to post from it.

Hi Scott,

It’s an error beyond my knowledge of Fusion.
I don’t understand the error message ‘missing = in XML’ as the .CPS file is no XML but JavaScript…
Let me test a few extra things and see if we can get someone from Autodesk to help us out.


Hi Scott,

Here are a few things you can try to troubleshoot :

  • download the .cps file again
  • after downloading the .cps file, open it in a texteditor (notepad or better) and verify the file is readible. Then verify it has V5 on line 16. This just to ensure you have the right file (I am a bit new to Github…)
  • save the .cps file into another location, eg. ‘my documents’ and then in the Post Dialog box, browse to this path for ‘configuration folder’.
  • Try the whole process with another .cps file (eg f360-easel.cps) to see if this makes any difference.

I am so happy with this custom post-processor, I want to make it work for you as well!

good luck

1 Like

Thx…I’m excited to try it out. On vacation right now. We’ll try it out as soon as I’m back.

Ok, today I had some time to try and figure out what was going wrong. When I downloaded the .cps file from the GitHub page it didn’t have the V5 on line 16 like you said. So on a whim I clicked on the “Clone or Download” button and in the .zip file the correct file is in there. Comes up correctly in F360 now. THX!

Now I just need to finish my “Honey-do” lists so I can get back to my SO3XXL projects. :unamused: