A couple issues after the first few days of experimenting

Hi all,
I’ve been happily playing…er, experimenting with my new XXL after building its enclosure (more like luxury condo, pics to come soon) and assembling it. I’ve had a lot of fun and learned a ton but I keep running into a few issues I can’t find info on when skipping around the forum or wiki.

The first is a bit of a stutter when jogging. When I manually jog, it intermittently pauses for a fraction of a second and then continues on its way. It only happens during manual jogging though, not during rapid positioning or homing. Also, there’s another, longer stutter sometimes when a job is running. It will pause for a second or two in the middle of cutting, say, a hole, as if it suddenly wondered if it had left the stove on, and then it just continues the job to completion. Here’s a link to a video of it happening. Sorry if it’s loud.

Second, I’ve run about a dozen jobs and this only started happening today, but, when I set my job zero and hit run, the Z carriage immediately goes straight up, hitting the limit switch but still continues going, until it slams into the plate over the Z motor pulley where it still tries to keep going and skips a couple teeth on the belt before stopping. Now it thinks it’s higher than it really is and proceeds to scream into the work piece to a depth of 1/2" or more. But it doesn’t happen all the time either. It did it several times this morning but then started behaving. I was able to cut a few test patterns, my sea of holes on my spoilboard, and surface my spoilboard, but now it’s doing it again. At first I though it might be going to low and the tension from the springs was causing teeth to skip on the belt, so I took them off for lower jobs like threaded insert holes in the spoilboard. That worked for that job but now it’s doing it on work pieces that are higher.

Lastly, every once in a while I’ll get a “limit switch hit” error even if it’s not depressing a limit switch and I have to shut off the machine and re-home.

Has anyone run into these problems before? Any help would be greatly appreciated. If it helps, I’m using VCarve Pro to Carbide Motion for almost all my jobs.

In VCarve Pro, check the retract height when you are configuring your toolpaths. You might accidentally have it going up (for example) 2.5" instead of .25 inches, which would cause the Z to raise up too far and hit the limit switch.

Since you have homing enabled, make sure your max X and Y Travel settings are correct. Look at your GRBL settings. In Carbide Motion,l go to the MDI window, type $$ send to see all your settings for $131 and $132. If these are still set to the defaults of 465, then you could be hitting the soft limits. X and Y max travel will be somewhere between 800 and 850mm.

$130=800.100 (x max travel, mm)
$131=838.000 (y max travel, mm)
$132=80.000 (z max travel, mm)

The stuttering while jogging happens on some computers — hopefully it will get better / go away w/ Grbl 1.1 and CM4.

The limit switch error shouldn’t happen — the default Carbide 3D setup is for soft limits, so there shouldn’t be any spurious triggerings, and when it does happen, it should be absolutely repeatable due to calculations.

Bingo! I think you nailed it on the first try. I checked Vcarve and it had a safe Z of 1.7". I don’t know when that happened, it used to be set to .25". I went back and checked other projects I’ve designed in it but haven’t made yet and, sure enough, the Z was set too high also. I won’t have time to test it for a few days but that certainly seems to be it. Thanks for saving me a lot of frustration!

I’ll check again but I’m pretty positive my limits are set correctly for my XXL, I’ve already been working outside the limits of a regular sized Shapeoko 3 with no problems. I remember setting that up in the settings a few days ago, come to think of it.

Thanks again for your awesome help!

Good to know about the stutter. I’ll keep plugging away and see if I get any more limit switch errors. It’s pretty early days and I’ve a lot to learn!

I believe the answers posted here on jogging (CM3 stutters during jog) and retract height are spot on. With regard to mid-job pauses, you’d have to observe whether CM is busy streaming commands or your PC is perhaps consternating.

The phantom limit-switch issue has been reported in the past, and the consensus in the specific cas I’n recalling was ESD induced through the dust collection hose (material based, in fact). If it re-occurs, I’d determine if the switches are giving a false positive contact closure via DVM.

Do the new version CM PCB’s have status LED’s for limit switches? Keep us posted as you work through your issues.


Thanks so much for the help. Would you mind explaining a few of your suggestions like I’m five? (Not far off mentally, really) How do I see the CM streaming commands or that my computer is hesitating? (Consternating sounds like my PC has anxiety issues)

What is a DVM and how do I use it to analyze for a false positive closure in the limit switch?

The CM does have indicator LEDs but I don’t know if the limit switches have them. My CM is mounted down inside the cabinet and enclosure I built for my machine and, unfortunately, I made it a little hard to access quickly.

When Carbide Motion is running your job, the “Run” screen shows the active command, command#, etc… if there’s an unnatural pause, you can make the correlation between your machine being in a paused state and whether or not there’s updating activity displayed. More diagnostic however to determine if there are resource issues with your PC, it’s better to observe operations using the Windows Task Manager.

With regard to limit switches if you get another unexpected false limit switch signal, disconnect each limit switch connection one at a time and use a digital volt meter (DVM) to determine if the limit switch is actually closed (and intermittent/defective). DVM’s provide continuity/resistance readings so you can rule out the switches themselves as the source of your issue.

1 Like

Perfect, I’m tracking now. I’ll do both of those checks. I think I’ll test the limit switches just for the heck of it. Thanks again for your help and patience!

Installing the latest version of Grbl and CM4 from CM solved the stuttering issue with my XL machine.

1 Like