A couple of problems in version 406

(Randy Glaus) #1

I tried an earlier of the 400 versions, don’t remember which one, but went back to v316 because the unstable version kept randomly losing toolpaths and tabs.

Tried v406 today and tabs are still not working right.

First of all, when working in Design and I group a few things together, that grouping is not preserved when going to Toolpath. All the pieces have to be re-selected one by one to create a single toolpath with them. The grouping from Design should stay intact.

So I created a toolpath, then clicked on Edit Tabs, added a few, click OK, and things looked great until I clicked OK to finish the toolpath, then the tabs were gone. I’m not sure why but a couple of times the tabs stayed, but now I can’t get them to remain at all.

Also, after I have created a toolpath, gone out of it, and come back in to add tabs by clicking the Edit Tabs button, it now says I need to select one or more vectors. So it has lost track of what vectors are in the toolpath I am editing! Very strange, and from this point on I cannot save tabs.

After going back to v316 I was frustrated because it didn’t have the nice features in the 400 series, so I wanted to go back and try it again. I’m kind of stuck now, can’t be satisfied with v316 because it doesn’t do some things I want to do, and can’t use v406 because it won’t save tabs which I must have.

2 Likes

(William Adams) #2

Could you send a file which exhibits these problems in to us at support@carbide3d.com along with step-by-step instructions for causing the problem?

0 Likes

(Randy Glaus) #3

Sure can! It’s taken me a little while but I’ve finally figured out what the problem is.

I’ll send the stuff now.

0 Likes

(kendrick Roland ) #4

Continuing the discussion from A couple of problems in version 406:

I seem to be missing the apply and done buttons under model tab. I only button I have is show 3D (V.406) I have to scale down my screen size in order to get the buttons to show up, but now everything is to small to read.

1 Like

(Jeff) #5

Just trying out 407 and in the Simulation the scroll to zoom is opposite of what is in the CAD view on Windows.

i.e.
CAD view - Scroll Up = Zoom In
Simulation - Scroll Up = Zoom Out

My preference is that Scroll Up = Zoom In in both (or maybe make this configurable based on user preference)

1 Like

(Randy Glaus) #6

Another problem, in 406 and 407, but not in 316:

When I open up a .dxf file which I purchased, some of the small drill holes are being turned into diagonal lines. That’s not very usable!

I have to re-install 316 to save out those parts as .c2d so I can use them in 407. If I load the .dxf into 407 and save the parts as .c2d they are still messed up. Have to go back to 316.

Also, I don’t mind a bit helping to debug your code, but perhaps you could make it a little easier. Make it possible to install more than one version at the same time. So far tonight I have reinstalled CC a good 7 or 8 times going between versions to figure things out.

And don’t reinstall C++ every single time. If you can’t make it possible to install multiple versions, at least don’t make me have to wait for C++ each time. You could do this for the unstable versions only.

There is a tools team where I work and they are constantly making changes or writing new code, and I know they can’t possibly test for every scenario. They test their code with small test cases and it works, but then I put it to use in real-world scenarios which finds things they couldn’t possibly find with small test cases, and I’m happy to do it because I know I’m helping to get the tools to do what I and everyone else needs them to do. It just needs to be easier.

0 Likes

(Luc) #7

Have you tried renaming the versions(e.g. Carbide Create 406) before installing a new one so they can be used concurrently? I’ve done that on the Mac.Since I rely mostly on VCarve, I have not done as much testing as you have so there may be issues in operating them concurrently but have not noticed any so far.

1 Like

(Randy Glaus) #8

Haven’t tried that, but I will. It’s so obvious that I missed it. The tools I use are generally in folders with the version number as part of the name. Doesn’t matter how many versions are installed. The tools people install them that way so I never even think about it. Thanks for pointing it out.

0 Likes

(Rob Grzesek) #9

I appreciate the bug report but there’s not much we can do without a file to test. Can you send it over?

0 Likes