Activate drill table?

How do you activate the drill table in CC so that the user will be prompted to install different drill bits? Right now, I can only pick a single drill, and I have 0.5mm and 3.0mm holes in the same design. “One-size-fits-all” does not :wink:

They are endmills, not drill bits — please don’t use drill bits unless they are rated for the speed at which the trim router turns.

You will need to use an endmill which is ~10% narrower than the feature which you are attempting to cut out.

To have tool changes active you need a BitSetter and to enable the appropriate post processor, Carbide 3D Shapeoko under Edit | Select Post Processor in Carbide Create.

If you don’t have a BitSetter please see: Working With Homing - Carbide 3D

Sorry - I should have spedified - CC = Carbide Copper, not Create. I’m milling a PCB. The milling operation is dialed in now, but I’m trying to figure out how to specify different drill diameters for the vias and through holes. Understood that these are really end mills (I bought the Carbide3D set) but in the PCB world we speak of these as drills, since it’s a single hole with only a plunge operation.

I think I just realized that I can activate the drill table by selecting “Custom” as my bit. But it only allows 5 tools there. Can I add more lines, so I can have more drill sizes?

Thanks!

2 Likes

Thanks for posting your question cgarman. I’ve been having the same issue and it’s good to hear I’m not the only one.

First, I’m using Carbide Copper on a Nomad and using PCB drill bits to make my holes. I’ve always seen these tools called ‘drills’ and they have the triangular type tip designed for plunging. Not the rounded or flat end like an endmill. I’m not sure why you would use endmills to plunge PCB holes like WillAdams is suggesting. Maybe it’s just a terminology thing about calling bits endmills vs. drills since they are being used in a CNC?

Second, I’ve been manually going into the .nc files that Carbide Copper creates and adding my different PCB drill settings.

If I select “Save as single gcode file” at the end of the Carbide Copper process, then the drilling section of the .nc file is blank. But if I select “Save as separate gcdoe (sp) files” then the ‘drill.nc’ file has all the drill locations. But each drill section uses the same plunge rate and so I have to go in and manually adjust them for each drill size. Also, the drill sections are missing the "M03 S10000” line to set the RPM, so I manually add that too.

I’ve never been able to get the “Drill Table” button to enable. It’s greyed out even when I select “Custom” for the tool. It sounds like you’ve been able to get the button to work. Do you mind sharing your settings?

I’ve tried Safari (on Mac) and Firefox with no luck. It would be great if I could set up 5 tools in a drill table. That would be enough for most of my designs.

Also, I’m using Kicad to generate my drill files. Maybe my drill file formatting is wrong?

This topic was automatically closed after 30 days. New replies are no longer allowed.