Active State / Alarm in universal G code sender

Hey Folks,
So I ran a job (in Carbide Motion) a few days ago on my Nomad that seemed to complete fine (I had to leave it unattended for the last few minutes of the job).

I just sat down to run another job and when I tried to jog to set my zeros, Carbide Motion did nothing other than showing its homing screen–no motion from the Nomad. I tried UGS, and for machine status, it says (in red boxes) Active State and Alarm.

When I enter $X the Alarm state goes to Idle. When I then click “Return to Zero”, nothing happens (other than a subtle brief sort-of-clicking sound from the bottom of the Nomad when I quit UGS or CM). When I click Soft Reset, I again get the alarm state.

I’ve moved all the axes on the Nomad to their limits with the unit powered down (can’t move them with power on, of course). I’ve quit everything and rebooted. I’ve even unplugged the Nomad and waited for the blue powersupply light to finally go off. All to no avail. I’ve run many jobs and never had this happen.

Mac mini with OS 10.11.5
UGS 1.0.9
Carbide Motion 3.0.357

Older software, I know, but it has always done what I’ve needed so I’ve seen no need to rock the boat. Any thoughts?

Thanks in advance.

Quick update:
I loaded a file in CM and clicked Run and indeed the Nomad comes to life. Not sure what it has in mind though (with respect to zeros), I paused that, then tried homing it, but still nothing…

Oh, and:
Nomad 883 Pro
GRBL 0.9

Thanks again.

Further update:
In CM, after clicking Jog, then Begin Homing, if I push the limit switch on the right side of the spindle unit exactly three times, everything moves (table, spindle unit) as though it will home. This is not true of any of the other limit switches. CM then asks me to “Click to Measure Tool”. When I do that, CM says “Measuring Tool”, and the spindle unit moves over the sensor to measure my end mill, then nothing happens; after maybe 10 seconds I get the message “Probing Cycle Failed.”


Check the cabling and make sure it is all tight on the pins of the controller board. Sounds like you may has some shorted cables. If you havent cycled the controller board you might want to do that also. I am assuming you have shut down your computer but if not, try that.

If none of that works, you probably want to to send in a support ticket.

Thanks Stacy–I’ll check out the connections and report back.

New USB cable in a different socket on the mac mini gives no joy. Looks like no jobs will be run tonight. :frowning:

Please contact if the standard troubleshooting techniques at: don’t address the issue.

Tried zapping the PRAM. No joy.
I also downloaded the grbl.hex but then it got complicated trying to reflash the Nomad (the tool suggested on the supprt page you cited Will is for Windows). I looked into other approaches but they required using the Arduono IDE which is way more than I have the time for tonight.
Gave Support a shout–maybe they can diagnose it from my HPI (description of current symptoms).
Thanks all.

Yeah, the whole re-flashing thing should get a lot simpler once a tool is worked up to upgrade everyone to Grbl 1.1 — will have to remember to re-write that page (should get a lot simpler) then.

1 Like

Jorge just walked me through some diagnostics and it looks like a board problem.

That awesome Carbide3D support strikes again: new board on its way!!

Thanks all!

1 Like