Advanced V-Carve not working properly

Hey all,

I’m trying to run advance v-carve on my Shapeoko 3 XXL but I’m having an issue. Carbide Motion does not recognize the different tool paths and, because it doesn’t recognize the different cutters, it carves the pocket and v carve in one pass, without allowing a change in tools. I do have the bit setter installed and Carbide Create is set to “Shapeoko 3 with homing switches.” Do I need to set Carbide Create to “GRBL” so it recognizes multiple tools? The bit setter seems to work perfectly (other than the light on it has never functioned) when I break my g-code up into separate tool paths. I’m at a loss trying to figure this out. I have some projects that could really use the advanced v-carve function. Does anyone have any ideas?

Thank you!

You need to use a BitSetter to manage tool changes or use a 3rd party tool to split the G-Code:

Since you say you have the bitsetter, it should all work nicely.

You will need to make sure your tools all have different tool numbers or CM won’t know the tool needs changing.

Thank you for your reply!

I’m not sure I understand. I am running a Bitsetter - which is from CC and it is enabled on carbide motion. The bitsetter does work but advanced vcarve does not - well, it does but it doen’t allow for me to change from a pocket tool to a v bit while carving. Does that make sense?

Thank you for your reply!

I haven’t used third party cutters yet but that is definitely good to know! - I genuinly don’t know why I can’t do advanced vcarves. I’ve watched a ton of videos and read through the Shapeoko install guides a few times but I have had no luck with this - I haven’t been able to do an advanced v-carve the entire time I’ve owned this machine. I thought the bitsetter would “fix” the issue and it hasn’t. I’ve done work arounds and that has gotten me through, but I really would like to save some time by using that feature.

Could you share the file?

Here are the files: Both the CCpro design file and the G-code for CM. I did this file just to figure out what’s going on with the v-carve, so I haven’t messed with speeds and feeds on this. I’m acutually running the file without material on the Shapeoko to see if it will ask me for a tool change. I just updated Carbide Motion and I’m running the file again to see if that fixes the issue.

Sargent Stripes_Advanced Vee (308.0 KB)

Sargent Stripes.c2d (59.3 KB)

Thank you for taking a look at this!

As Gerry said, your tools need to have different tool numbers assigned in Carbide Create (not the type of bit, the actual tool number). So, for example, your 1/4" end mill could be tool number 1 and your V bit could be tool number 2. That way, when Carbide Create generates the tool path, it will insert the tool change command. If they are both tool number 1 Carbide Create thinks they are the same tool and will generate a continuous tool path.

Does that mean I need to start a new tool library and number each of CCs cutters?

No, the tools in Carbide Create should be properly numbered to work with the BitSetter in Carbide Motion.

In order for this to work you need:

  • BitSetter properly configured in Carbide Motion:
  • CAM tool set up to output G-Code files with tool changes — For Carbide Create, Carbide 3D Shapeoko selected as a post processor in Carbide Create under Edit | Select Post Processor
  • each tool which requires a tool change having a different number

If you continue to have difficulties post:

  • screen grab or your Options screen under Settings in Carbide Motion
  • a photo of the tool over the BitSetter at the position it is configured for along w/ a screen grab of Carbide Motion confirming the location
  • a screen grab of your Edit | Select Post Processor screen in Carbide Create
  • a .c2d file, generated G-Code, and step-by-step notes of how you are setting your origin relative to the stock and managing all tool changes

Thank you for your help Will!

I have

  • verified the bitsetter is installed properly according to those instructions.
  • verified Carbide Motion is properly configured for the bitsetter - to the best of my knowledge.
  • I have tried both of these settings (“GRBL” and “Support for Shapeoko WITH homing switches”) and neither have made a difference.
  • I have no idea how to verify that Carbide Motion can accept tool changes.
  • I’m only using CCs tool library so they should all be numbered.

When I start my machine:

  • Power everything up
  • Connect my laptop (Windows)
  • Initialize the machine
  • Load new tool, using the bit setter ( Which works wonderfully)
  • I use my bitzero to identify the lower left corner of my material as the zero position for all three axis.
  • Load my file and start carving

I’ve attached all photos that you asked for and a few extra. I hope something stands out to you.

Thank you!

I don’t see a .c2d file.

Sorry about that. Here it is.

Vcarve test file.c2d (56.9 KB)

Are you sure the pocket tool is small enough to cut the pockets. For instance if you choose #201 1/4 inch and the pocket is smaller than 1/4" the pocket tool is ignored and only the v bit is used. Does your simulation look normal? Try using a smaller tool for the pocket and see if that works.

I downloaded your file and changed the pocket tool to a 1/16" tool and here is the simulation. You can see around the outside is the v cut and the interior with a 1/16" tool looks different than your original file simulation.

Original simulation:

1 Like

Sorry for my delayed response, but I just got the time to dig in…

The simulation shows that it should work (via CC), and you have enabled Area Pocket Tool - good!

There’s definitely something odd going on though. All of your pictures in post #11 are definitely helpful. So I think @gdon_2003 is onto something. I think the current simulation is misleading (perhaps try a third party gcode simulator?); this is what I’m seeing…

Notice the step-over and all of the paths - this is a departure from gdon’s picture showing the “original simulation”. I’m on build 614. Gdon’s simulations are more representative.

The issue seems to be that the pocketed areas are too small for the #201 1/4" end mill. So, to get a little technical, the BitSetter operations are initiated when there is an M6 command. In your original .nc file, this is what shows up…
Sargent Stripes M-Command Screenshot 2021-09-26 065856
“M0” precedes both tools, not “M6”. I did verify via .nc file that the tools are called out with different numbers (201 and 1).

Now, when I double the X and Y parameters of your stock and scale the design 200% as well, I don’t touch anything else, this is what I see in the simulation…

…and now, I see the M6 commands show up in the .nc file.

Sargent Stripes M-Command After Scaling Screenshot 2021-09-26 065856

Try a smaller end mill to use for pocket clearing :slight_smile:


@gdon_2003 @RoughDraft40 Thank you guys so much for the help! Yesterday I updated Carbide Motion from build 525 to build 537 but I never re-booted my computer. Today, I came into the shop, made the change from a 1/4" end mill, to a 1/16" endmill and re-ran the updated g-code. Everything works now!!! I think the problem was with build 535. I’ve tried smaller paocketing tools in the last few days and CM wouldn’t recognize the tool change, despite the size of the cutter. After the update and re-boot, everything is working perfectly.

Thank you all for your help!!!


You mentioned you changed tool size but was ignored. Did you save the toolpath after tool change? When you save a toolpath there is no automatic update of toolpath.

1 Like

I did update the tool paths, and then saved the saved file (I’m pretty diligent about that). I’ve had my shapeoko since January and that feature has never worked for me, even after I installed the bitsetter. However, I updated the CM software, updated the tool path with a smaller cutter, rebooted everything, and now I’m running the machine without turning on the spindle to test this issue. So far (and, I think this is because I updated the software), the software is finally picking up my tool changes. It just stopped and asked for a tool change as I was typing this. I’m so thankful for everyones help because it seems like it’s finally working!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.