Arc Endpoint Error CM 4.0.428

I realize this is dredging up old issues, and I extend apologies, but I’d like to keep cutting while I wait for an updated workstation that will support the newest version of CM.
I have a two very large nc files generated by Fusion 360 that have to be split to run on the CM version I have on an old MacBook limited to 16 bit and the newest version I was able to get to run on it is 4.0.428.
I was able to split and run the first file yesterday in two parts. The current file requires splitting into thirds to make the size limit. I ran the 1st part successfully but when I attempt the second file, I receive “Error in line 19: Arc Endpoint Error”
Tried a few variations including the suggestions from here
and from this post which had a similar(same) issue and indicated a fix with CM 4.0.11.

If anyone is able to assist with a fix so I can continue cutting, it would be greatly appreciated!
EDIT: I made the first file split of the original file at line 909013.
Here are the files:

What post processor are you using?
Can you export in mm?
Can you share the Fusion file?

1 Like

Using Fusion for the post processor. Interestingly enough, the Document Unit wasn’t set. Checked the last project, where splitting the file worked, and it wasn’t set either. So yes, I guess I could try exporting in mm. I’ll have to ask permission to share the Fusion file as it’s on loan so I can make the project. I’ll let you know about that if it’s necessary.
Here’s the post process settings:


And here’s the Fusion post process config file saved as an nc file:
carbide3d.cps.ArcEPError.nc (25.9 KB)
And thank you for having a look!

Out of curiosity, can you export with the default GRBL post processor rather than the carbide 3D?

I’m not very versed in Fusion yet, but I’ll give that a try right now…

That’s a BIG file…give me a few.

Yes, sorry. The first one I split was only about 30MB, so just two files worked for machining.

I’m confused on your split. You said you split at 909013?
image

But the second file starts with:

image

Line 909015 matches your start point in the other file (line 14), but that arc in question is well before that in the original file (line 909000).

I’m halfway through your file from the grbl post (past the error you had there) and it’s checking out. I have a feeling that if I checked your original file, it would check out as well. The problem looks to be in the manual split.

That’s a rough cut/paste to handle with a text file that big. Maybe you could split the job in fusion and export separately.
You’re cutting a max depth of one inch. Start the first operation with a Top Height at the top of your stock and the Bottom Height at 1/2" down. The next operation would start at 1/2" down and finish at full depth. Post each op separately.

P.S. I’ll let you know tomorrow (today, I guess, but later) if the file checks without errors.

Yes, when I split the file I tried to get it at a point where the cutting was happening at the front of the job so I could see what was happening as I restarted. This is what I did for the file that worked two days ago and apparently I caught a break re-initializing the arc information when the second run started. You’re correct of course about splitting such a large text file, and that’s why I add the layman’s markers as I go in an attempt not to botch it up.

I knew that the arc info would need to be in the second run, so I copied what I thought was the arc in from line 909000 in the first file and inserted in at line 19, just below the preamble in the second run. Apparently I’m missing another trigger that helps Carbide Motion interpret this correctly, hence the error.

As far as Fusion, I have a huge amount of help from the creator of the file and he has willingly given me a lot of his time, just thought it would be worth an effort on my part not to bother him with assistance in help splitting the file. So if I can find the trigger to add to the preamble, maybe I won’t have to.

Then again, thank you for your time Neal!

Hey @MikeG,
I forgot to tell you that the newest file you shared did encounter an arc error later on in the file.
Try using mm as I think that takes care of the problems with these arc errors.
If you want to pm me the Fusion file so as not to release it to the public, I can try an export on my end.

I read that using mm in the forums that using mm does fix it, from one of your posts I suspect.
I did receive permission to share the file and will send via PM in a few minutes.

@neilferreri - The creator of the file @BubbyDog came back right after giving permission and continues to amaze with his willingness to assist us Fusion amateurs, so he’s working on splitting the file now.

Folks like you make this a great forum, thank you for your efforts!

1 Like

I suspected. :wink:

Though you might still hit that error, closer to the end.

G3 X2.0787 Y4.3974 I-0.0003 J-0.0652 (line=2436562)

That was the only arc error.

1 Like