Argh....... Y axis stepper woe

First, be aware that I’m not using Carbide electronics or firmware…or for that matter steppers. If you’re not willing to step into “totally off the reservation” this post isn’t for you :slight_smile: I’ve been away from the machine for about 6 months for…reasons, came back to fire things up and check them out before running a job and immediately ran into difficulty. Things were working 100% ok when I last used the machine.

Things that have “not changed” since I last used the machine: Software, firmware (STM32 GRBL), wiring, or anything mechanical. I say this in a bit of jest…I haven’t intentionally made changes to anything, but clearly something must have changed, just haven’t figured out what yet.

My problem:
If I run with both Y steppers (Y1 and Y2), about every 4-6 inches I lose steps just while jogging. It sounds like steps being lost, and can be measured as steps lost (jog away from a spot, let it get hung up a couple times like this, then jog back, and it’s not at the same point)

Experiments:
If I run Y1 with stepper drive DY1 and disconnect the drive (DY2) from Y2 it’s smooth (but obviously gets itself jammed at an angle eventually)
If I run Y1 with driver DY2 etc, same thing.
If I run Y2 with DY1, Y2 disconnected, same thing… Run Y2 with DY2 alone, same thing.

This leads me to believe:

  1. both drives are independently working ok
  2. the steppers themselves are working ok
  3. Wiring to the steppers from the drives is ok
  4. Wiring to both drives is ok.

Both drives are the same make and model, both have the exact same settings (D542S)
The stepper cable to Y1 has the phases opposite of Y2 (so it runs in the opposite direction)

I’ve already taken a look at the step pulses on a scope at the drive, and they’re looking ok, without excessive ringing. No strange noise on either enable or direction lines. I’m beginning to question the ground there though.

I’ve thought that maybe the two stepper drives are fighting each other, but that seems like it would need to have either a different number of microsteps configured on the two drives (they’re set the same), or pulses not making it two one of the drives…but they both work ok independently.

Anyone have ideas on where to look to chase this down?

Have you put the scope on the PSU to see if it’s holding it’s output stable?

This behaviour could well be a collapsing supply voltage from an EoL power supply.

3 Likes

Good point, will check it.

Found a grounding problem. Then discovered the Z axis is way out of calibration. I have an HD Z, so not sure how that happened. Working on that… sigh.

1 Like

is your $102 still 320 ?

Yes. I think I’m still having steps skipped on Z, argh.

Have you checked it’s still greased and not just that the rails have gone high-friction (based on another thread here) ?

1 Like

The Z blocks were in fact short on oil. Solved that problem. That bottom set of blocks requires some amount of disassembly to get to the oiler holes (not tons - remove the router and the top blocks from the plate then hold the top blocks out of the way).

Should have thought of this, thanks @LiamN!

Y still giving me a little trouble, but much better than it was.

2 Likes