Bad Controller!?!

I have a ton of stuff to cut, but my pro isn’t wanting to corporate!

About 5-10 minutes into my cut, my connection to my Pro gets cut and it cannot find the cutter. Gives me a “Cannot open port for cutter: Serial Port: UnkownError”. I turn off the Pro and back on and it will connect and re-initialize and cut 5-10 mins and disconnects. :triumph:

Here is all the troubleshooting steps if went through:

Bought a new USB cable: Same error
Downloaded Carbide Motion V5, loaded config to cutter and ran file: Same Error
Reset my Controller: Same Error
Stole my sons computer, downloaded CM, configured, loaded file: Same Error
Created a new file in Carbide3D instead of Fusion360 file: Same Error

Only one more possibility, and that is my controller is bad…am I missing something??? I’m super frustrated and have a ton of stuff to cut.

Both laptops are super new and expensive, latest CM software, and the file is good.

Any ideas? I popped a beer :beer: and just staring at this thing and a pile of projects that’s not getting finished.

It is most likely a static electricity disconnect. There is a list to help identify the solution to work through. I’ll see if I can find it.

For me, I grounded my machine, bought static dissipating dust collector hose and grounded the steel coil in it, and have not had a static disconnect in years.

Side note:The last one I had last year was due to not remembering to connect the ground wire to the hose. I have a “temporary” setup that I threw together two years or so ago. It works, but I need to fix it.

EDIT: Found it. @WillAdams posted it on another thread where someone had the same issue.

EDIT2: Just want to say that different people end up with different solutions. For me, it was the 4" anti-static hose and 2-1/2" anti-static hose and grounding the machine and hose to a common ground plug that got my EMI disconnects to stop. Some people have better luck with ferrite beads, but for me, they didn’t work. I even tried the USB opto-isolator, but that did not work either.

1 Like

Great info!

My dust collecter produces an insane amount of static electricity. I’m going to take a hard look at my setup and play around with it. Going to study that link more tonight.

I’m going to run the file again without my dust collector on and see what happens

1 Like

Here’s what I did when I was first encountering the EMI disconnects:

I would grab the dust collector hose with one hand while it is running and collecting dust, and leave it there for a minute or two.

Then I would take that hand and touch the metal frame of my SO3, and I would get an immediate disconnect. That is how I turned my “random” disconnects into a repeatable thing.

Good luck.

Also, the less humid the air is, the higher the static potential. Humidity reduces the ability for static electricity to build up, so it can happen more frequently in the summer if you do not heat up your work space.

OR in the winter, when it is really cold outside, and you heat up your work space. The increase in heat causes the relative humidity to drop significantly, making it incredibly dry in your workspace, and increases the charges that can build up.

I have the highest chance of EMI disconnects in the middle of winter, when I heat up the outside air of ~30-40F to 75F and drive the relative humidity way down, lower than it is in the summer.

1 Like

I was looking at my hose and it was touching the router carriage metal.

I live in Colorado and is insanely dry here (CO Springs area).

This all makes sense. Going to the big box stores tomorrow to fix this.

Running my file right now to see what happens with no dust collection on.


Yep, the exact issue I was having. Static electricity :zap:

@MadHatter look for a beer in your email. Sending it over now :joy:

Thanks again!


Static. If your controller was bad it would not self heal. Electronics usually work or not. Moving air and certain material create static electricity. When the static discharges the usual victim is the usb. Ground your spindle and vac hoses. Some buy usb isolator (cheap).

1 Like

@Merick01 if you do your best and still don’t manage to fix it, don’t despair just get a hold of the Carbide Support team, they are very helpful in getting this sorted out, it’s pretty rare these days.


You’re welcome! Glad you were so quickly able to identify the issue. Like @stutaylo wrote, if you can’t get it figured out quickly, definitely reach out to the Carbide team. They really do want to get you cutting again and will help you get there.

@MadHatter @gdon_2003 @stutaylo

Everything worked out great. Thanks for all the help

I ran two file cuts, one without my shop vac, and the last one with it. I made sure when I had the shop vac hose not touching anything and no issues

Tomorrow I’m going to work on grounding the vac and cutter properly. Need this baby to keep ticking.

Been sanding for the last hourish. 3 down 7 more to go

1 Like

3rd cut while sanding…no issues