bCNC config file?

I started using bCNC today, as some of the features sound promising.

However, I find some things confusing: The work area is shown opposite from the homing point, if that makes sense? I found the config options, but they do not seem to do much? For example, I am able to move the head past the work area limits even though I have soft limits ticked. I also do not see a way to “load” these settings to the machine. Is it done on the fly?

The bCNC documentation feels quite basic, so I wonder if someone has a working config file for the S3 XXL? I have a feeling seeing one, would clear up some of my confusion?

While I am not using bCNC, I have a feeling that it behaves like other G-code senders (e.g. CNCjs) in that the work area limits that they allow to configure are used for display purposes only, and do not have any effect on the machine behavior at runtime (which is managed entirely by GRBL in the controller). Soft limits is a GRBL feature, which uses its own limit values ($130, $131, $132), those values where probably set by Carbide Motion when you first configured your XXL. If you modified values inside bCNC config file, I think they would only reflect in the displayed work area, which would be a simple visual cue when you load a G-code file that it might not fit.

I don’t know about the work area being shown opposite from the homing point (but don’t you mean the zero point ? Homing point is typically not displayed in G-code senders)

1 Like

Thank you for the input.

It is confusing indeed. If those soft-limits are there in Grbl, why can I run the Shapeoko into the rails by using the manual controls in bCNC? On both sides of each axis actually, even past the limit switches?

With "opposite’ I mean it shows you a yellow rectangle as work area. This rectangle has the homing point on its upper right corner and the arrows indicating the point away from there.

It does show the homing point by the way as X -3 Y -3 Z -3 once the homing cycle is complete.

do you have $20 set to 1 at GRBL side ?

I see, then I suppose the intent in bCNC is to display the machine coordinates reference rather than the work coordinates (from set zeroes). Machine coordinates system matches that description (homing point in the bottom right corner, Z axis pointing up, X axis pointing right, Y axis point towards the back. It first seems like a slightly disturbing convention, but then makes a lot more sense when using the work coordinate system, where X/Y/Z positive values are “where one would expect them to be” with reference to the set zero point.

Attempt at a description here in the ebook, FWIW

Thank you for the pic. That is exactly what I think is going on. I guess, I have to get used to thinking in “negatives”.

do you have $20 set to 1 at GRBL side ?

Now that I think about it, I do not think so. I certainly have not entered it myself. When bCNC is connected one of the screens is config. There I can see “soft limits” and “hard limits” but those check-boxes are not ticked. I have tried ticking them, but no change occurred. That’s what I meant earlier, how do those settings to the machine? I will go back to CM tomorrow and play around with those settings.

I wlll also have to do more reading, such as this: Frequently Asked Questions · gnea/grbl Wiki · GitHub

:grinning:

Is there some kind of “Apply” button in sight ? For bCNC to apply those parameters, it will need to send them out to the machine/GRBL at some point, but I don’t know when/how it does it (sorry, I’m not being very helpful and someone with bCNC knowledge would be in a better position to help!)

You can enable soft limits manually if you wish by typing $20=1 in the BGRL/G-code console.

Found this bCNC - foss-toolchain-mpcnc

Copy these over in the command window.
Check with $$ if they have been stored correctly.

WARNING:
although grbl stores the settings in the EEPROM and should apply them immediately,
I sometimes needed to power off/on the controller for the (correctly reported
settings - check by $) have been effective! 

Will try tomorrow. Also, curious to find out about those tick-boxes.

You probably don’t have a work zero offset, meaning your work zero is the same as your home. bCNC will show your machine space with the axis arrows at the back right until you actually home the machine. If you have a work offset, that will be reflected in the visualizer.

1 Like