Bit drives too deep after zero

I’ve seen some topics about this on here but not an answer for my issues. Starting a new project, I already had a 1/8" end mill in the router. I opened CM, turned on Shapeoko, and initialized. Since I already had the 1/8" end mill, when CM asked to make sure there was a tool before sending to BitSetter. I continued so the BitSetter took the reading from the end mill which was probably about 1 1/2" from the collet. Got my BitZero to zero all 3 axes using the end mill. First cut for this project was 2 keyholes on the back side. CM asked for tool change, I changed to keyhole bit and it went to BitSetter. Started project and on it’s way to the first cut, it plunged deep into the wood. This happened yesterday as well. Same issue except for the initializing process I already had a .25" ball nose in so it initialized with that. My first tool was a 1/16" endmill so i zeroed with the 1/16" endmill and it crashed into the wood. Could this be because of the tool selected when initializing?

1 Like

How are you managing the tool change?

If you use the tool change button to change the tool, then go to Z +6mm is the tool 6mm above where you expect to begin cutting (assuming zero is at that point)?

I’m using a BitSetter when CM cues to change tools, but it doesn’t happen between tool changes, it happens after getting x,y,z after machine initializing.

How are you using a BitZero when CM cues to change tools? It’s supposed to use a BitSetter at that time.

Yes, sorry. I meant BitSetter, not BitZero.

BitSetter at initialization is comparing the bit you have in the router to the last time you set z zero. The last z zero may have been the last time you used your machine. So when you initilize and the BitSetter sends the router to the front you should do only two things to change a bit.

  1. Use change tool in run screeN.
  2. Change to requested tool when prompted by cm.

So let machine initilize, request tool and measure bit. Then change tool through run screen and let BitSetter do its thing.

Now jog over and set your zeros. Load new file and if bit not already loaded install requested tool. The BitSetter will measure your tool and compare bit to last zero and set that zero.

When BitSetter measures a tool it is comparing the current bit to the last z zero set. If you manually change a bit the BitSetter has no reference to set z zero. In this case manually zero or use BitZero to sync the bit length with BitSetter and only change bits when prompted.

1 Like

this is exactly the process i go through and it does the same thing, just ruined another piece. It doesn’t do it every time.

More often that not it turns out to be a subtle variation in the specific steps you took, and it’s easy to get caught. A typical example would be doing the normal workflow, then realizing you have the wrong tool installed, changing it and re-zeroing, but then CM lost it’s tool length reference.
If you stick 100%, always, to the process Guy mentioned (only ever changing the endmills when prompted OR using the Change Tool button), you should not get that issue.
If you can identify the detailed set of steps that led you to a wrong cutting depth, it will be interesting to troubleshoot it.

Note that there are other reasons why the tool would plunge too deep, the main one being having a large retract height and colliding with the top of the at the beginning of the job.

1 Like

I used the exact same steps guy mentioned. The same steps i always use. it still does it, but it is not every time. I just ran it again and now it doesn’t even go down to the workpiece.

Would you mind writing the steps you just took, starting from machine power on, in lots of details ?
It’s unfortunately the only way to help you figure out what is going on…

1 Like

start CM and wait for it to load, plug in usb, turn on shapeoko. Initialize. when asked for a bit to test bitsetter i click ok (this time i already had a 1/16 bit in the router). machine goes to bitsetter and tests. I then put the bitzero on the workpiece and zero x, y, z, selecting the appropriate bit. I then load the file, remove the alligator clip, and click start. once the router moves to center to request bit i remove the bitzero, change the bit (for this a 1/32), and let it run to the bitsetter. I then start the job.

Allright. The key thing then is to figure out if the depth offset can get from time to time is from an incorrect zeroing, or from the bitsetter adjustment at job start.

  • for single tool jobs you could temporarily disable the bitsetter, runs your jobs like that and see if you ever get the issue again. If you do, you’ll know it’s not the bitsetter part.
  • when you do use the BitSetter, right after you zero with the BitZero, and before running the job, manually jog to Z0 and check that this matches the top surface of your stock (or bottom, if you choose to zero there). You may be able to catch a wrong Z0?

Finally, always make sure the Z zero reference in your design file (stock top or stock bottom) matches where your actually zero. There have been cases where folks unintentionnally had the Z zero reference changed to stock bottom in their c2d file and were zeroing on the stock top, and then that’s another reason for getting a job that runs in the air, hovering one stock thickness above the stock instead of cutting into it.

1 Like

I have run into that problem myself. It occurs so randomly that I could not figure out what was causing it. So, I adjusted my workflow to Set Zero and then recheck zero (jog to Z +6mm). So far, that has helped.

1 Like