Bit Setter Problems

I have owned my Shapeoko 5 Pro for just over a month now and have had nothing but problems with it. Most of the original issues have been sorted out with the exception of the bit setter. For some reason, my bit setter does not feed information back to Carbide Motion. The first time i realized this was when the spindle tried to put a bit straight through the bit setter plate and just kept chugging away trying to push down. After getting into the settings I realized that, even though both the red and green lights on the bit setter itself are operating normally, the signal isn’t reaching Carbide motion somehow. I’ve tested this by going to the settings menu and tripping all the other switches manually (XYZ). They all show up just fine when triggered but the bit setter never does. I have had numerous conversations with many different people at Carbide 3d and no one is able to help me. They just keep shipping new parts out without any success. Thus far I have replaced the bit setter itself, the wire that connects the bit setter to the front plate, the front plate itself, the wire that runs from the back of the front plate to the main wiring harness, the main wiring harness itself and 3 different controllers! The first controller had to be replaced because it wouldn’t connect at all with carbide motion. The second controller works well with the exception of the bit setter not reporting to it. The latest controller that just arrived today won’t even power the CNC on! The people at Carbide 3d have been exceedingly unhelpful so i’m hoping that someone on this forum can help me figure out what in the world needs to be done to fix this machine. I can run simple programs by just splitting up the work paths and resetting the z axis myself but unfortunately without the bit setter i can’t use the Advance V carve option which is what I intended to use the most with this machine. Any help the group is able to provide would be greatly appreciated.

We are trying to research what happened here.

I checked, and you are next up in the queue, so you should be getting a ring presently.

Carbide 3D sent me yet another (this is the 4th) controller and this still did not fix the problem with the Bit setter not reporting back to carbide motion. Beyond that, it actually created a new problem where as soon as i turn on the CNC the spindle turns on and the only way i can turn it off is to hit the E stop or to kill the power to the controller. As I mentioned before, I have a total of 4 Controllers from Carbide 3d and each one of them is faulty in a different way. The first wouldn’t connect to Carbide Motion at all. The second was the best but it still wouldn’t recognize the bit setter (all wiring has also been replaced). The third controller wouldn’t even power the CNC on and now the fourth doesn’t recognize the bitsetter and automatically turns the spindle on without any way of turning it off short of killing the machine. I was told by the rep i spoke to that he would be personally testing controller #4 to ensure that it worked properly and he’d also be packaging it “carefully” himself so it wouldn’t get damaged in transit. Well, the controller doesn’t work and the packaged arrived like it always has - one single piece of crumpled construction paper sitting on top of an otherwise completely unprotected controller in the cardboard box. I find it hard to believe that my luck is just that bad to have been shipped four faulty controllers but seeing as how they all malfunction in a unique way I don’t know what else it could be. I thus far have not been at all impressed with Carbide 3D’s response time to my problems or their ability to correctly diagnose and resolve my issues.

Any resolution? I just got my 5 and am having the same issue. So far haven’t cut anything yet. I’ve called support and had to leave a message. So far no call back and now they’re closed.

Yes, I finally got a resolution to my bit setter problem. Oscar made sure that the 5th controller they shipped me was actually tested and after installing it my shapeoko 5 pro was finally able to use the bit setter. When they reach back out to you make sure you tell them that someone needs to personally test the controller before sending it out.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.