BitRunner Maybe Flakey Connection

I have a Shapeoko XXL with the BitRunner. It has run fine since I got it but last week I took the cover off the board and had to disconnect the cables. Today I was trying to run a job but the router did not come on. I reseated the cables and it seemed to run but during a job the router quit running.

I was not paying enough attention but the switch for the BitRunner was in auto and the red light was on. I noticed when the router did come on the led would turn green. I think on one time that the router failed to come on the led light was off.

I took my board cover off again and plugged in the cables and the BitRunner worked fine. So I put the cover back on and I may have solved my problem. I did set a job to air cut to prove the BitRunner worked.

My question is in the MDI interface I sent the command β€œ/M3” and Send but the router never came on. What would be the correct command to set the Router on through the Bitrunner at the MDI command line? Just in case I need to trouble shoot the connections again.

Add a speed setting? I believe that’s necessary as well.

I will try that but I think is did send β€œ/M3 S18000” and I will try β€œ/M3S18000” but I will try again later.

My Shapeoko broke the Z homing switch on the HDZ so I cannot try right now. I dont if it is important but I will try

/m3 s18000
/M3 s18000
/M03 S18000

I notice that some of the gcode has M3 and some has M03 not sure if the leading zero is necessary. Will report back. I think being able to turn on the router for troubleshooting may be important in the future.

I did order a new controller from Caride3d so that should be here next week. I have always had a flakey usb connection and the metal shield around the usb connector is loose.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.