Bitsetter Button is Sticky

OK, I finally got around to installing my bitsetter, which I bought a couple years ago. At first the button didn’t move at all, but after a good push with my thumb, it now travels down/up, but it feels “sticky” going down, requiring too much pressure. I’m afraid I’ll break a skinny endmill. Can I just put a drop of (vactra oil? WD40? Something Else?) on the side of the plunger to free it up? Or do I need to take it apart to clean it? I’m not sure what the guts look like, so don’t want to get oil inside without an informed opinion. I’d like to keep it simple if I can. Shapeoko 3 by the way.

Usually they free up by just pushing the button up/down a couple of times — if need be, it can be unscrewed, see the diagram at:

and if that doesn’t help, let us know at support.

I left out the part that one of those 3 screws to take it apart was installed by a gorilla, and the head stripped out when I tried to take it apart. So If I can solve the issue with a drop of oil or something, that would easier.

OK problem solved. Oil didn’t help, so I drilled out the siezed/stripped screw and took it apart. There was some kind of sticky tan adhesive (or maybe dried grease) on the plunger shaft. Cleaned it off with some lacquer thinner on a Q-tip, and now the button works great.

1 Like

I don’t think there should be lubricant on it. The dust will collect and cause issues,

Good Luck

1 Like