Bitsetter button


When the button of the bitsetter is not pushing down when my router is homing.

Please help.

Please write in to — let us know:

  • what you did
  • what you expected
  • what actually happened

and we’ll do our best to assist.

It’s a fairly common issue that I’ve seen mentioned quite often on various groups. I believe (please correct me if I’m wrong) that Carbide3d is gluing the aluminum button top to the actual button surface. Sometimes this glue works a bit too well and makes the button “immovable”.

This also happened on mine. I was able to apply “heavy” downward pressure with my thumb to break the button free and it now works just fine. Other people have used dead-blow hammers or a block of wood and a hammer to free the button.

Since this seems to be happening quite often, maybe Carbide3d could take a look at their QC on this particular issue

when I got my SPXXL the button would not push down manually. The first time during initialization the button popped when being pushed like it was stuck and broke loose. Luckily it has worked fine since.
Hope you get it worked out.

1 Like

Either push down with your thumb or give it a sharp rap with a plastic mallet. I would not recommend hitting it with anything steel. If you dont have a plastic mallet put a plastic handled screw driver on top of the button and tap with a hammer. I mean tap not a hard swing.

Do you mean the button is impossible to push (even manually), in which case the other answers apply, or that the router won’t go low enough and you can a limit switch error before the endmill reaches the button ? In which case you should lower the router in its mount.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.