BitSetter Misteps

Well I had a close call this morning, I was running a job and the Shapeoko ran the first toolpath using the 201 bit with no issues then I was asked to put the 301 bit which I did and the spindle moved towards the BitSetter and descended on the BitSetter to probe the length but I noticed an issue, the endmill was not aligned with the BitSetter button, it was further out in the Y direction. I was happy that I spotted it and that the pause works during the process, the spindle retracted and I saved the bit and the BitSetter from a sharp poke.

Why would the Shapeoko lose/gained Y steps all of a sudden? I did not crash the spindle, everything ran fine for the first toolpath. It is a bit worrisome and I will have to pay very close attention when I change bits. Anyone else experienced something similar?

I have used it with about 50 toolpaths or so since I got it and it has worked very well. Never once has it missed the bit setter location I set. I was adjusting a clamp one time and obstructed the x/y travel for a moment by accident and that threw everything off but never had an issue other then that.

1 Like

Loose belt or loose stepper bolt or crashed into left side with HDZ are possible reasons

I tried again and I’m definitely losing steps, the second time it was a bit off the first for the first toolpath. I was getting close to the max Y at the back so I moved my stock thinking it may have touched the limit switch. With the stock closer to the front, I tried a 3rd time and missed more steps, it got worse. and the holes started fine then I heard the stepper make noise and the holes were about 3/4in off. I checked the V wheels, and one was just a bit loose, belts are also fine but I don’t know that it was the issue, I cleaned all V wheels, gears, belts then I was called for dinner. I will try again tomorrow, maybe a bit of dirt in the V wheels was the cause and hopefully I solved the issue.