Bitsetter Z-axis help needed

Hi all,

I just got my Shapeoko 4 bitsetter and am puzzles as to why it doesn’t work for me.

Here’s a recount of what went on:

  1. I have bitsetter permanently enabled, even on jobs where there isn’t a tool change.
  2. I start the machine and initialize the cutter with a #201 bit securely installed.
  3. The cutter initializes and asks me to install a tool (which I have already done so).
  4. The cutter then begins probing with the bitsetter.
  5. I load a new job in and set the XYZ home position.
  6. I start the job and the cutter prompts me to install a tool (which I have already done so).
  7. The cutter then begins probing with bitsetter.
  8. The cutter prompts me to start the spindle up, and then begins the job.
    9, Immediately, i realize the cutter was digging too far into the material (6mm instead of 3mm).

This happens a couple more times, and after stopping the job and checking for Z, my Z home position changed.

This however doesn’t happen when bitsetter isn’t enabled.

Any help would be much appreciated~!

You procedure looks fine - keeping the same tool in place from initialization to running is fine.

The 3mm difference sounds similar to another forum member’s issue. Is it possible you haven’t selected the right Z-Axis in Carbide Motion and sent the relevant configuration to the machine?

1 Like

Hm… not quite understanding what this means. I simply head over to the “Jog” tab to set my home positions. Thinking it was bitzerov2 screwing up on me the first time, i did it manually the 2nd time, only to arrive at the same problem.

Different tries would lead to different variations in the Z-height though. Sometimes it’ll be 2mm deeper, sometimes 1.625mm, etc. I have no clue what’s going on or if my bitsetter is just buggy (which i doubt?)

Did the other forum member manage to solve it? I’ve done some research on this forum, but it does seem like I have all my steps right.

Hey Jeff,

Within Carbide Motion there is a settings/config section. In that section, you need to choose the machine that you have and then also select the type of Z-Axis you have. For a ShapeOko 4 I think that’s a Z-Plus. You then have to send the configuration to the machine.

The reason is that different types of Z-Axis move different distances for each electronic pulse it receives.

1 Like

Oh yes, I have already done this when I first set my cutter up (:

What i find interesting is how my gcode works fine without bitsetter enabled, but gets all wonky with it enabled.

How are you setting zero?

Usually a ~3mm or ~1/8" discrepancy is using the BitZero and not having it positioned as expected.

2 Likes

I have tried both setting zero manually and setting zero with the bitzerov2.

Manual:

  1. I would bring the cutter down to the wasteboard and slide a piece of paper under it till it barely grabs it,
  2. I would then hit “set zero” in the Jog tab and click on Zero Z-Axis.

Bitzero v2:

  1. I would place bitzero v2 on the wasteboard.
  2. I would bring the cutter down to the bitzero v2, about 5mm away from the face of it.
  3. I would then initialise probing sequence, ensuring that bitzero v2 doesn’t wobble (as it isn’t exactly very stable when placed on the wasteboard).
  4. Z-height will then read 21.5mm after the sequence.
  5. I will bring the cutter down to the wasteboard, and z=0mm at the wasteboard.

There is only 1 configuration file for the Shapeoko 4 and it’s labelled as “Shapeoko 4”

1 Like

Understood…

So just for clarification, the issue is with the BitSetter, and it happens if you zero using manually or with the BitZeroV2?

Plus, you zero to the wasteboard and not to the top of the stock. So this means your stock is always precisely the correct height, yes?

For the cases where you use the BitZeroV2 and zero X,Y and Z, do you manage to hang the BitZeroV2 over the edge of the very corner your wasteboard? For XYZ probing, sitting it on top of the wasteboard doesn’t work properly.

1 Like

It happens both when I zero it manually and when i use BitZerov2.

Hmm, well, my stock might be 0.2mm off or so, but my gcode shouldn’t go below z=0 because I set the program zero to be at the bottom of the stock too. Correct me if i’m wrong haha. I have also trammed and surfaced my wasteboard, so I doubt there’ll be a Z-deviation that large.

When i use BitzeroV2, i use a 2nd sacrificial wasteboard, so it’s rather easy to hang it over the edge, just like one would do if they were to zero the top of their stock.

I will run some projects this weekend and provide more info.

I encounter this same issue. No problems what soever when bitsetter is disabled. Happens 4 out of 5 times to me when it is enabled. I have ruined many projects because of this issue.

SO3XXL
bitzero v1
bitsetter

Config is correct on CM with original belt z drive.

1 Like

Kinda sucks considering we paid extra for bitsetter to improve our workflow, but instead it’s ruining our projects! haha!

When my bitsetter arrived, it was also very sticky and was jammed. I had to dismantle the button and give it a good clean (there was junk preventing the button from being pushed down)

I certainly hope what I’m experiencing is just user error, which is what I hope to establish this weekend.

Looking forward to more data points. You appear to be doing everything properly, I think.

One additional thing to be very careful of is what you do with the BitZero when its not being used for a probe cycle.

The BitZero is the same machine input signal as the BitSetter.

So it is possible that if you leave the BitZero or the clip in contact with the chassis of the machine when not in use, it could be that the BitSetter will think its switch has been pushed in as soon as the endmill contacts the metal of the button.

Because of this I hang my BitZero on the wooden wall of my enclosure just in case. Also, I have a spindle, and due to the way I have things grounded, I don’t need the BitZero clip. But as a consequence, if I merely touch the BitSetter it will trigger.

1 Like

Oh yes, I am aware of this, thanks though!

I have mine stashed away at the side, but hanging it at the side of the enclosure sound like a splendid idea. I’ll be doing that instead! (:

Could you share on how you went about doing this?

It was more happenstance than design. The G-Penny spindle is grounded, which means the endmill ended up being grounded. Since the alligator-clip/magnet is just “ground” itself, it’s no longer required to close the circuit with the BitZero.