Bitzero and Advanced Vcarve issues

So I’ve come across two issues today. One, my BitZero V2 will not calculate the Z correctly. I am loading in Carbide motion for it to probe X,Y and Z and I set the bitzero flush against the corner as directed, but when I start the job it goes to the correct X and Y but the Z goes through my entire piece and it is reading the MDF board as my stock, lucky it was a practice piece. So I decided to not use the Bitzero and manually set the zero. Now I am trying to do wooden inlays with Advanced VCarve but it does not give me the option to change bits. For example I should be starting with my 1/8 end mill but instead it tells me to start with my 30 degree V bit and proceeds to do the entire job with the 30 degree. I’ve been searching for answers all day and have been in contact with tech support but no one can seem to figure it out. I do have the select post processor on Carbide 3D shapeoko. Any help would be greatly appreciated.

The BitZero should work — usually the problem you describe is caused by a disconnect in how you are setting the origin in the file and how you are setting zero relative to the stock.

For the Advanced V carving, it requires that one set the post processor to be Carbide 3D Shapeoko (or Nomad) — then it will make tool which will allow for a tool change in Carbide Motion.

Post a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it and managing any tool changes, and a photo showing an attempt at cutting still in place on your machine.

I home the router, it then goes to the bit setter, I then tried zeroing the bit with my Bitzero (did not work) I decided to manually zero my bit. I started the job it instructed me to insert my 30 degree when I thought I would start with my 1/8th end mill to get a flat bottom for inlays. I proceeded to install the 30 degree and it did the entire job with my 30 degree without giving the option to change bits.

Goerss female practice (196.6 KB)
goerss female practice save as.c2d (440.9 KB)

We open the file and verify the job setup:

and verify that the G-Code matches:

Then source a suitable piece of stock and secure it to the machine:

Power up and connect to the machine and install a 1/4" probing pin and allow the machine to measure the probing pin.

Place the BitSetter and jog over to the correct position to begin probing:

Test the unit for contact:

Select Probe | BitZero v2 | Corner:

Begin Probe

To verify the position, Rapid Position to Current XY and Z+6mm

Unfortunately, no 30 degree endmills available, so regenerate the code w/ an available tool:

Verify that the file preview matches:

in Carbide Create Done and get back to the Run pane and load the file:

Start Job | Start

when prompted insert a #302:


allow tool to be measured

file begins cutting:

1 Like

and the file cut fine:

One other possibility does come to mind — is the V endmill you are using significantly shorter than the probing pin you are using?

Is the machine bottoming out when trying to reach down far enough to cut? Verify that the machine can move so as to cut as deeply as the endmill needs to be moved to cut.

I realize that works, it did the same with my 30 degree. But the problem is that it should have a flat bottom, meaning I need to use an end mill bit also. It does not give me the option to switch bits… I have another job that the letters will be significantly bigger and a V bit simply won’t work to cut it all out. My issue is Advanced VCarve not giving me the option to change bits mid job.

Doesn’t look like the 1/8" would fit. It won’t generate a toolpath for the tool if it’s not used.

Generate the gcode for the bigger lettering. If there are two M6s, there are two tool calls.

That makes sense I thought the 1/8 would be big but it was showing up in the stimulation that it would work… I originally had a 1/16 bit but it broke when I tired using the Bitzero since it plummeted it so deep. I will try the bigger letters tomorrow. Thank you for your time.

You need to make the bottom shallow enough to allow the V endmill to fit and you need to select an endmill for pocketing which will fit:

Note that the area for a pocket needs to be at least 10% wider than the endmill.

So you were right it was only because I had the 1/8 end mill which wasn’t needed. I tried a bigger piece and it allowed me to use multiple bits… although my BitZero issue is till happening, have yet to figure that out so I continue to zero it manually.

This topic was automatically closed after 30 days. New replies are no longer allowed.