Bitzero Z-Axis too High

I just got my Shapeoko XXL set up and installed the BitZero option. On my first attempt, I ran the “Probe” routine and everything looked like it was working fine. The spindle touched the Bitzero in each of the Z, X, and Y axis. However, when I ran the job, it acted as if my material was like 2 inches thick… moved around and up and down, but way above my material. I tried to redo the Probe routine, but same results. Then I did manual “zero”, and it ran my project perfectly. Any ideas here?

The BitZero has a recess under it with a lip on 2 sides. For the X,y and Z probe you sit the lip on the corner so the lip over hangs the piece being measured. If you only want to set Z you set the lip on top of the piece being measured. In CM you select which way you are measuring and a tool. Many have set the BitZero on the wrong surface if you measure the Z with the lip over the edge the Shapeoko will cut too deep, If you set the BitZero on top with the lip on top the and measure X,Y and Z only you will cut air most likely, depending on how deep the cut eventually goes.

Depending on which measurement you are selecting the height of the lip is offset in software.

1 Like

Thanks for your suggestion, however, the “lip” was overhanging the material correctly. Even if it wasn’t, I would expect the end mill to travel above the material at a distance equal to the height of the little lip, not several inches.

Can you capture the log output when you do the probing?

Are you configured for the correct Z axis?

1 Like

How do you have Several Inches of “Z” Clearance? Did you not install the wasteboard and supports?

When the spindle is retracted it is almost 4-inches above the wasteboard. My material is 3/4" thick.

Not sure what you mean…???

I will try to capture that on my next attempt with the BitZero.

What Z-axis do you have? Stock? Z-Plus?
Is CM configured for THAT Z-axis?

I have the Z-Plus. Also, keep in mind that when I did a “manual” Zero, it worked perfectly.

1 Like

Was the carve depth correct?
A manual method of setting zero says “zero is right here”. No matter what your settings are, the Z will go right there. When you probe, you say “zero is 22mm down there”. If the machine’s Z axis is moving the incorrect number of steps per mm (due to selecting stock Z instead of Z-plus), it will move less than 22mm down to what it “thinks” is zero.

1 Like

The Z-Axis setting is "Z-Plus (Leadscrew). (See screen shot for “settings”) Is this what you are wanting me to confirm? Maybe I am supposed to “check” some of the other boxes??? (Sorry about all the newbie questions.)

Can you get your grbl settings? Open the log and send $$. Specifically looking for the value of $102, your Z steps per mm.

Ok, first off, thank you so much for all your help.

I was making a video to upload for you to see the steps that I was going through to start a job, including ‘zeroing’ by use of the Bitzero, but when I ran the job, it worked perfectly! So, no need to bore you with my video.

I have no idea what I was doing wrong before, but I’m sure it was something. Anyway, all is good for now.

Thanks again!

2 Likes