Build 304 won't save toolpath names etc (solved)

I can’t seem to name a toolpath now with the latest build 304. It defaults to it’s own toolpath number. This was always very helpful in being able to name a toolpath with your choice of wording. Any plans to implement this feature again?

Also, with the new tabs (which is nice) there doesn’t seem to be a way to get the true width/height dimensions with the new feature. Once you create a tab, if you click on the resize button, the w and h are just the dimensions of the outline and doesn’t include the thickness of the new path. I hope that makes sense.

1 Like

@kdur - Which Carbide Create platform are you running: Windows or Mac?

1 Like

I’m running the Windows platform.

I just tested this and there is a bug if you are adding tabs - it wipes out the toolpath name when you click OK.

Here are two workarounds you can use until the next release.

  1. Press Enter after typing in the toolpath name
  2. Go back into the toolpath and rename it after clicking OK.

Could you post a screenshot of the scaling trouble you are having?



Won’t work for me. I clear out “toolpath 1” and enter “profile”. When I click OK, it still shows up as “toolpath 1”.

No worries on the scaling. I can manage that.

1 Like

just so it isn’t overlooked - I was editing my post at the same time you were posting the screenshots. I found the bug, see my previous post for a workaround until the next release.

Thanks for finding this one!


This workaround does not work for me. I can name the first toolpath, but then no others. I am running Windows 10. Is it possible to rollback to the previous version? This is really a problem for me.
Edited since original post: I’m not using tabs.

Came here to see if this had been reported, workaround is working for me.

1 Like

Would you please check your OS settings? It may be that there’s some input setting which interferes with this.

To rollback to the previous version you should be able to run the CarbideCreate.exe file for it in your downloads folder (should be “C:\Users<YOURUSERDIRECTORY>\Downloads”)

Thanks for your response. I figure out how to make it work. Your instructions were:

Press Enter after typing in the toolpath name
Go back into the toolpath and rename it after clicking OK.

My workaround is very slightly different.

Create toolpath. Change what ever you need to. Change the name then hit enter. Click the OK button.

I don’t need to go back into the toolpath again to rename it. Just enter and then click OK.

1 Like

I found an oddity with the 304 CC build after successfully using the workaround for the path names. I’ve successfully used my MAC with the Nomad through many versions of CC but after 304 two different anomalies manifested:

  1. After successfully cutting with the first tool and then changing tools the RPM of the Nomad changed to a value different than my manual input value. I think it changed to the automatic RPM for the selected material (just my guess). I had set the speed to 6000 RPM and the speed was closer to 1000 (my guess). If I end the job, go back to CC and write over RPM and Feed inputs, disable the successfully cut path, and resave gcode it works well for the previously failed path, until the next tool change. I repeated this process on three different projects. Once a path works, through this process, it will work the next time I run it.

  2. Unexpectedly the Nomad stops while the spindle continues to rotate. This happened while moving to my project and when cutting on the project. I thought it was just a random glitch and restarted the machine and all went well for awhile. When it happened a third time I was very frustrated with the need to restart and, as though just looking at the machine would help, I noticed that the spindle was actually moving very slowly…at 10 mm, barely noticeable…I had not noticed that before. I can recover from this event by pausing and then quitting the project and resaving gcode forward from the point of failure. The 4th time it stopped I was more attentive and again the velocity was 10 (mm).

I use the Nomad at a public library and I am the primary user and patron-caretaker for the CNC; I only had a few hours to experience these anomalies this past Saturday. A couple of factors that may impact my experience:

  1. I built the projects at home with CC 303 (MAC laptop) and then upgraded to CC 304 before milling (using my MAC laptop on the library Nomad). I really have enjoyed seeing the new improvements to CC and look forward to each new version.
  2. The library replaced the previous USB cable because it seemed to cause glitches…and it’s a public library so the ‘new cable’ is likely not new.
  3. I’ve experienced glitches with the Nomad over the 18 months I’ve used it and restarting Carbide Motion or my MAC (rare) has fixed what I would call typical events…but the shift to a fixed speed seems odd and the RPM change, coincident with CC 304.
  4. I am a newbie, self taught. I really don’t know more than what I experience.

I am going to go back to 303 (if I still have it in my downloads) and I have an old 290 build on a windows machine (both seemed more stable than 304). Still think you guys have built an awesome product…thought I’d share in case it helps pinpoint needed fixes. I am pending receipt of a power switch from Carbide Support; several variables going on, I know.

1 Like

Nomad Velocity to 10.JPG

Out of curiosity what was the specified feed rate for the job when it was going slow? I may have the same issue

FYI- Build 305, posted today, should fix the toolpath naming bug and I think it fixes the bug with the wrong feedrate, which kept pockets and vcarve toolpaths from getting the correct feeds and speeds when the file was reloaded into CC.


Rob good timing, I just confirmed the speed issue wasn’t me hitting something stupid after regenerating the gcode :slight_smile:

Confirmed 305 doesn’t produce the issue I had with it dropping to 10mm/min speeds