C3D Spindle questions

I’ve got my Pro XXL ready for duty, but am a bit confused about the spindle. I find only one video and it is pretty basic. In the video, when the VFD button is pressed and the machine is turned on, there is a display starting at zero. The button turns red, but I get no display. The screen is black. The buttons on the front of the VFD (except for the big round button) seem to have no effect. I’ve checked that the cable to the controller is properly plugged in and the power is on (red button lite). I tried the commands recommended in the video (M3S10000) but nothing.

I did make sure that the spindle and the bitzero were setup in C Motion

Am I missing a step???

Adendum: Now when I initialize, it does exactly what I would expect and goes to the far right corner of the bed. But after a few seconds it says I need to make a tool change and comes forward. When I click ok, it goes back to the far right corner and the Z axis will go down and bottom out. I have to hit STOP to stop it from trying to go further.

I hope this is just a stupid user trick and I didn’t make the mistake of buying the spindle.

Since there is no gcode loaded, I am not sure why it would be doing that.

Did you configure the position for the BitSetter?

Power up, connect to the machine, go to Settings | Options and disable the BitSetter — you should then be able to initialize.

Once you are initialized, you can configure for the BitSetter.

The configuration option for the BitRunner simply doesn’t bring up the on/off and speed prompts — it’s kind of nice when first using the machine to not enable it.

that fixed the problem with the initializing.

I still have the Spindle problem. :frowning:

Let us know about the spindle difficulty at support@carbide3d.com and we’ll get it sorted out.

Just in case you haven’t tried this, press the round button on front of vfd again. I think the red light might go on when it’s “off”/spindle locked out. Don’t quote me on that.

1 Like

Did you hit it with a hammer? Lol just kidding dont do that.
I wish there was a manual for the spindle as i have 0 clue on the buttons on the front and the functionality of them, but so far its been working and i havent had to mess with them.
I also used the YouTube video to figure out how to set it up. Also to turn it on with the red button, it wouldn’t work and the i figured out you had to push the red button in lol.
The black switch next to power cord is on i assume since the button lights up.
Good luck!

if you want to test if the spindle runs, go to the MDI screen and type
there… that should cause it to start spinning at approximately 13k RPM
(M5 or M3S0 will stop it)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.