Calibrated Belt super slow cutting

So I followed the formula Drawn distance / Measured distance x 40 = New step mm.
I made 3 holes in a right triangle formation, 8mm diameter



For holes A to B, the eye to eye distance was 50mm, but I measured the 2 closest edges between A and B (42mm) I was getting 42.30mm when it was suppose to be 42mm length. The holes were 8mm diameter, 4mm deep.

so 42/ 42.3 = 0.9929078014184397 x 40 = 39.71631205673759/mm


Did this for Y ($101) as well. B and C (X- $100)

After doing this, I noticed the The A-B distance was 42.01 , but the B-C distance was still off but that wasn’t the most peculiar thing…the weird thing was as I was pocketing the holes (4mm depth) it ended up going super slow, almost like it was stuttering, like someone was pressing play and pause rapidly. I was cutting stuff earlier and it was fine didn’t’ do this, after i entered a new $100/101 value…it started doing this.

  1. What did I mess up?
  2. is the distance for AB = Y, and BC = X or am I wrong?
  3. Does it matter if I use mm measurements?
  4. I couldn’t figure out the command or how to see what the current step/mm is… like what is $100, $101, $102. When I clicked on log , it was blank, and a number counter kept climbing up but no information was being displayed. Is it suppose to que up or when I hit log, it should be instant? When I tried to input MDI, $$ nothing happened.
  5. what is the command to reset to default settings, should Ctrl + X work? or how do i reset the x/y step/mm to factory. (or is it just as easy as $100=40)

GRBL: v 0.9 ( I think…)
Shapeoko 3 XXL ( I bought this 4 weeks ago)

5/16 4 flute end mill
DOC: 3mm
Step: 3mm
Feed: 1000mm
Plunge: 300mm

Material: MDF (I will retest on a sturdier material tonight)

Thanks in advanced, I got about 4 hrs before i’m off work, then i’ll be at it all night trying to dial this machine in.

The only thing I can think of is you inadvertently changed one of the acceleration settings.

Please compare your settings against the defaults at:

If that’s not it, perhaps something has gone wrong w/ the machine which isn’t related to the Grbl setting?

Ok, will compare settings tonight.

If I want to reset to factory default, is there shortcut command? or I have to input manually.


Step 5: From the info pane, you can load the default Values by pressing ⌘+1 (ctl+1 on windows).

When I compared the values, they were the same.

I changed $100/101 to 40 and tried to cut some holes. This is what was going on during the cutting.

This is after doing a reset
Ctrl + 1 to reset the GRBL values, and not touching anything.

I want to know how to see the Log statistic of G-Code in CM + GRBL 1.1 now it is different and I am sending my codes blindly. They guide me please. Thank you!.

I need answer !. Please , help me .

Just in case this happens to anyone else.

So I turned off the machine, and let it sit for 15 min, I thought maybe it had something to do with the stepper motors being super hot even thou they weren’t doing anything. When I switched it back on, everything was normal again, no more stuttering. Not sure if this was related to cooling it off, or when I shut down the machine, it truly “reset” everything in GRBL.

1 Like

In CM, go to settings (top right corner). On that page, look for “Open Log”. This should open up a window in your default internet browser. In CM, go to MDI window and type in $$ and hit “Send” to see your current settings displayed in the browser.


I do not know what happens, but I’m not working , at the beginning a list that does not stop, but does not show our basic G-Code, to say something: $ 20 = 0, I can not see the G-Code that I have assumed Yes, but I can not see it, something is happening!.

Look at how different we were in the past or my question would be: What am I doing wrong?

I agree with everything, I enjoy talking about Carbide 3D, but I also want to learn, if it is annoying to want to have a better understanding and comfort in the software that CM works with, if I have my belts in the tension required by the S3 also I want to see it easily in CM, but at this moment it is not comfortable for me, maybe I’m doing something wrong, I do not know, I come here to help but I also want to help me understand my mistakes, I do not come to bother anyone, I feel discriminated against for not having the English language as my mother tongue, however, here I am trying to communicate in the best way, I apologize. Thanks to everyone, they do not know how much I have received from you.

Please accept our apologies for your difficulties. You should not feel badly about your mastery of English — it’s excellent (far better than my one year and 1 day of high school French). If it’s more comfortable, we do have a partner who is fluent in Spanish — just write in to and we’ll have @Jorge respond in kind. We’ve another employee who speaks French, but that maxes out our linguistic capabilities I’m afraid (I’ve pretty much forgotten the Korean and Japanese which I learned when I was younger).

Please write in to w/ any difficulties which you are having and we’ll do our best to help.

The company is too small, and with limited resources, so direct support beyond that isn’t feasible, but the community has had some success at putting together glossaries in other languages — thus far we have:

If anyone wants to volunteer to do another language, we’d be glad of any.

@JoseD3 I think if you made your own thread, it would get more assistance. You kinda jumped into my thread and it got tangled up a bit.

Not sure about 1.1, but I have to scroll up after typing in $$ to see the settings. Can you use your mouse wheel and scroll up on the log after sending $$?

1 Like