CAMotics not respecting metric tools

When I import gcode created in CC into CAMotics, all the flat mills show up as 2.000 mm in diameter. The other specs also appear to be replaced with a generic value. This happens to the Carbide 3D native tools as well as ones I’ve customized. This does not appear to happen using Imperial units which I would much rather avoid.

Do you use a comma or a period for a decimal separator?

FWIW, I posted a file for these at:!topic/camotics-users/0GLqFDkJm18 which seems to work. (But which looking at now, I see is in Imperial).

I’ve been using decimals when I’ve had to enter. But much of the time I’m just checking the mm box. Are you refering to a specific location? There seems to be numerous places in CC where mm must be set individually.

I saw that posting at CAMotics, I’ve emailed Joseph with the same issue. I’ve also imported your tool set specs into CAMotics. I thought to try editing your “tools.json” file to metric. Use comma separators here? Can I add my custom tools to this as well? Might this work? (I’m about to try. What text should I substitute for “INCH”?)

I’m afraid I’m mystified and grasping at straws — using the Imperial tool file seems to work okay with .nc files in metric though. Going to actually experiment now.

  "102": {
    "units": "MM",
    "shape": "CYLINDRICAL",
    "length": 12.7,
    "diameter": 3.175,
    "description": ""
} (258 Bytes)

Hey, exactly what I tried. It didn’t seem to work, I tried again with “Metric” versus “MM” to no avail. But I’m seeing some tentative success if I load your imperial set into CAMotics and change each tool to to mm, save that as the default, then open on starting CAMotics.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.