Can not operate Carbide Create

I have been able to design on carbide create for about a month and now when I open the program I get the usual blank stock and that’s it. No options to open, click, etc. I am thinking about uninstalling and reinstalling. Has anyone had this issue?

1 Like

I use Carbide Create only to do my G-Code to cut flat surfaces and work excellent .
Sometimes do little errors but 98% work real good.

I reinstalled and it works. Hopefully, this will help the next person having this issue.


Seen it on both my mac and windows operating systems. Uninstalling and reinstalling seems to work. Still get a “CARBIDE CREATE IS NOT RESPONDING” spell periodically. If it continues i will unload it again.

To be fair, I also had this issue recently but with Carbide Motion instead of CC. It worked fine for a long time, and then suddenly the program would crash upon opening. I removed the program and reinstalled, and it works fine again. My suspicion is that it was a Windows update of some sort that caused the problem. Everything else on that machine was constant other than Win updates.

1 Like