Cannot connect to carbide motion

I just purchased a Shapeoko xxl and just completed assembly. I cannot seem to get it connected to carbide motion. I have tried restarting the computer, turning everything off and on etc.

Please check things from the beginning:

  • power supply plugged in — green light on it?
  • power supply connected to machine — steady light on the control board? If not, make sure that if your power supply cord has a switch (tiny thing, easily overlooked as a ferrite bead) it’s switched to on
  • machine connected to USB and one gets USB connection and flashing lights to indicate that?
  • if all that checks out, press the reset button — if that then allows you to connect, let us know at

See the article at: — if none of the above helps, let us know what you’ve tried thus far at and we’ll do our best to help.


I have tried the steps above. The computer recognizes the Shapeoko and says it’s working properly. I have carbide motion v4. I feel like it made some progress, because in my log it shows there is communication with the machine. Could it be possible that they did not update the gerbl to at least 1.1?

Yes, the machine should have shipped with Grbl 0.9 which works with CM3, but usually CM4 reports a version error.

I’ve been having issues with mine as well. I updated to Grbl 1.1 and am using CM4. Any time I turn the machine back on and fire up CM4 it refuses to connect. The only thing that seems to fix it is running the updater and reflashing with 1.1.

I suspect you have an out-of-spec part on your board — pressing the reset button on the controller ought to work as well.

Please contact — and we’ll sort this out.

Sorry did not get back right away, I have mine up and running. CM3 works just fine.
Thank you!

Hi there, I’m new to this form and to the world of CNC. I just completed assembly of my SO3XL and I am very impressed with the design. I’m now ready to perform the first project, however; after I downloaded carbide motion to my windows 7 PC, I launched the application and got a pop-up notification box with a string stating that it could not find the application. In addition, I have the router turned on and the cable plugged in my laptop. I will try to provide a screenshot of the notification.

I could really use the help. Thank you!

The community has some notes on this at:

Update the video driver[28] or try the Standard VGA video driver.
Try a different machine.
Uninstall and re-install.
(Mac OS X) uninstall USB drivers for other FTDI devices.
OPME (program for USB Dell Printers) can interfere, requiring that that program be uninstalled in order for Carbide Motion to work.

Carbide Motion just quits. A possible fix is to open the program in 256 color mode:

  1. right-click the executable (Carbide Motion.exe)
  2. click Properties
  3. click the Compatibility tab
  4. check the “run in 256 colors” box
  5. click OK

Similarly, changing the colour mode to 256, starting the application, then changing back to 32-bit has allowed some users to run the program successfully. (Notably on Dell Inspirons)

If none of that helps, contact us at and let us know what you’ve tried and step-by-step:

  • what you did
  • what you expected
  • what actually happened

and we’ll do our best to help you sort this out.

I have it running now. I uninstalled a program that was running in the background and repaired 120.dll. Now I’m working on the limit switch. Thank you for your time…

1 Like