Cannot install fonts in Windows 10

Microsoft in their infinite wisdom has done something to prevent new fonts from being installed. It used to be so simple to drag a new font into the font directory and you were done… now nothing happens!! I’ve tried many of the suggestions on the web, but with no results. Any suggestions would be greatly appreciated!
Don

download the font, double click on the font and the font installer will appear showing your font, click install at the top and the font should install provided it is the right type.

3 Likes

Thank you for your prompt reply. When I do as you instruct for an extracted TTF font (as normal), it tries to open in a generic file viewerFont
See attached.

There is something fishy here, the OS seems to think you need to use IrfanView to open the file. Maybe the ttf file type is associated with irfanView instead of the font viewer.

Windows 10 uses Settings instead of Control Panel to make changes to file type associations. Right-click the Start button (or hit the WIN+X hotkey) and choose Settings. Scroll down a little and select Choose default apps by file type . Locate the file extension you want to change the default program for.

2 Likes

I had the same problem recently. In your case IrfanView has made itself your default font viewer. You want to change that back to Microsoft Font Viewer, or at least get that app to open the font so you can install it.

Right-mouse click on the .ttf file and select Open with / Windows Font Viewer. When that opens click the “Install” button and you should be good. BTW you probably need to be logged in as an administrator or have administrator privileges to be able to install fonts.

You can change the default font viewer by right-mouse clicking on the .ttf and selecting "Open with / Choose default program… and then select Windows Font Viewer and check the “Always use the selected program…” box.

Disclaimer: I’m checking these steps on a Win7 system, but Win10 should be very similar if not identical.

2 Likes