Cannot Open Port Error

Sweet Christmas!!!
Now most of you know I’ve been running my shapeoko for the last couple months no problem.
Due to family business, I’ve had to take probably 3 weeks off. So I haven’t touched it in 3 weeks.
Went from working just fine, to me going out there today and this is all I did…

I kept having the Update Message in the bottom left of CC so I downloaded and installed the update to that. Kept CM as it was.
I went to run my job.
It started up just fine.
Probably lasted 1 minute
Stopped Dead in it’s tracks (my eyes were on the router because I always really really watch it start off when using 16th inch bit) So I turn to the laptop screen…it says “Connect To Router” I’m like “WTF???” knowing that this means I pretty much have to restart. I click it, and it shows this message: Cannot open port for cutter: Serial Port: UnknownError

I’m frantic. it’s in a downed position with my new 16th bit. I just know it’s going to break it up when…“if” I can initialize it. I pull out the USB cable from the laptop, put it back in. Click Connect to Router again, again the error message appears. Oh No! Only thing I can think to do is click the rocker switch for the power off and back on. I get some connection. and luckily the initialized “Raised” first before it moved, so I did not break bit. I come back inside, to my desktop (and for some AC as my shop does not have any) to search here for the same. I cant find anything but some people had some other message and someone said to uninstall/reinstall CM, so I did that. Tried it all over again. and got the same thing. So now I’m feeling like, my almost 3 grand worth of equipment and time has just gone down the toilet??? Please someone tell me otherwise???

Please contact us about this at support@carbide3d.com

There is a basic page on troubleshooting connection issues at: https://docs.carbide3d.com/software-faq/can-t-connect-to-machine-or-jog/

Sounds like you’ve got the usual suspects covered (forgot to switch on, plug in unit, &c.) — one thing which I think merits checking is thermal shutdown — could you move the unit to somewhere w/ AC? (I keep mine in the basement for this reason, plus figure the more stable temperature reduces calibration issues).

If you’re under warranty (12 months), this is covered — if you’re out of warranty, we’ll still work with you to get this resolved.

Occasionally I get the same error. I think it is because I turn on the Shapeoko with CM already open and click “Connect to Cutter” too soon. Usually if I power off the Shapeoko, turn it on and wait a minute or two I usually get a connection. The controller on the Shapeoko boots pretty fast but you can be too quick on the trigger and try to connect before the controller is fully up or sometimes the controller may come up in a less than optimal state so the power off and wait seems to work for me.

2 Likes

Hey thanks for the response. That was not the case for me though.
I move slow in “life” so I definitely notice I move quite slowly when using this machine. I actually had: 1. the machine on. 2. Carbide create. 3 then opened up my new install of Carbide Motion.

I’ve emailed the support address you provided

1 Like

Hi Teddy,

Sounds scary! Can I ask was the router running during this time? Have you installed an E-Stop yet. If not then I would focus my attention on getting one setup as a priority.

Also on the support front, trust me, I had some big problems recently and like you as a new user, I was terribly worried about it. But I must say that Carbide 3D got me back up and running and looking back on it, provided the best support I have ever experienced. One way or another they will sort it for you. Thanks again @Jorge

Hi there. No, no, no. it wasn’t running. The CNC stopped the router from moving, but it was in a plunge. I stopped the router from running, I just could not remember (cause I was in a panic) if/when I would be able to initialize the machine, it did a Raise function first or not. Because Imagine, power going out, power coming back on, then it just drags back to home? If in the down position, it would have torn some stuff up, but it raised up first, so that was a blessing. Yea, I’m in conversations with support right now, we’re trying a few things out. Hopefully, Lord Willing, it’s nothing major.

If everything is completely off you can gently move it by hand (not too fast) and make it safe take the bit out etc.

1 Like

If you are worried about the bit take it out. Not likely but cables do go bad. Have you tried another cable?

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.