Can't add a tool in carbide create

Hello, I’m new to CNC.

I’ve read the tutoriels to add tools in carbide create, but I must be missing something since I can’t :frowning:

  • I’ve created a new library.
  • right click -> new tool -> end mill
  • I fill up all the informations
  • I click OK
    but then the “Included angle” becomes grey, and I can’t validate, it won’t let me create a new tool.

I don’t understand, any idea what I’m doing wrong ?

Thank you very much for your help

PS : I’m running on a mac, with carbide create up to date.

Screenshot 2020-03-05 at 09.26.26|690x402

does this help ? Not in front of a computer right now sorry

also, si tu préfères de l’aide en francais n’hésite pas à me contacter

Included angle only works for V endmills.

An endmill is assumed to have a 90 degree angle.


will allow you to enter one.

Thank you for your answer.

However, It’s the same when I try to add a V Mill with a 90° angle, it’s like the ok button doesn’t work.

Do you have comma set as your decimal separator?

I’ve tried both coma and dot, doesn’t change anything

You need to have the decimal separator set to period if having it set to comma is causing the problem.

what @WillAdams is hinting at is that your French version of MacOS may have “,” declared as a decimal separator, and you could try setting it to “.” instead. But I think you would have seen the same issue when typing ANY numerical value in CC, not just in the tool edit window.

1 Like

Both “.” and “,” and even a number without decimal doesn’t let me add a tool

In that case, please update to the current beta:

If you still have difficulties let us know the specifics at and we’ll do our best to work through this with you.

Still the same, I’ll write to you on the support

This topic was automatically closed after 30 days. New replies are no longer allowed.