Can't go back to same zero on jig after upgrade from CM3 to CM4?

I just upgraded to CM4 from CM3. Prior to that I was using a jig to hold down and build parts. In CM3, I’d perform homing, everything would reset to -5,-5,-5. Then I’d go G0 x-411 y-322, to move directly over hold down hole that I made with the wasteboard tutorial. When the bit was over that, I’d zero x and y and know I was in the same position as last time.

Now with CM4 I go through the same process homing to -5,-5,-5 and when I enter G0 -411 y-322 I’m 3mm or 4mm off my mark with CM3. Could someone please help me understand what changed between CM3 and CM4?

Just trying to understand what you’re describing. In CM4, after you home are you clicking the “Clear All Offsets” button on the “Set Zero” page behind the “Jog / Position” screen? If you do that (making your work coordinate system match the machine coordinate system), your G0 rapid to your jig location’s absolute coordinates should match up.

Of course, if you have something set incorrectly/differently in your GRBL settings post-upgrade, that could factor in – for example, if you had calibrated for step size in your previous settings but reverted to the default when you upgraded. I may as well post the link to How to Calibrate the Machine for Belt Stretch, since that will always be part of the responses to all positioning-related questions. :smiley:

ClayJar, thanks for the help. That’s exactly what I did. I cleared all offsets. But then the G0 didn’t match up. I had a minor tweek that I made to $102 for a z adjustment, which I made upon upgrade. But that was to the z axis and I’m off by what I eye-ball to be 3 mm in the y-axis. Looks like my old mark is about x-411 and y-319. But for my jig to work, I need it exactly zeroing where it used to, and I’m also concerned if there’s something else going on I don’t understand.

I’m trying to come up with a fault tree for what you’re seeing, and everything I’m coming up with seems either unlikely or eliminated. Basically, all I’ve managed so far is:

  1. Physical homing change, e.g. limit switches. (Just a software update? Eliminated.)
  2. Steps per mm, $100 through $102. (Eliminated, yes? It’d have to be almost a full percent off on $101 to yield the magnitude you’re reporting, and I imagine it’s one of the first things you verified.)
  3. Other GRBL settings. (Seems unlikely, but if you had vastly out of family settings on rates or accelerations, that could hypothetically cause lost steps, I’m imagining. I believe stock is 5000mm/min for the $110s and 400mm/s^2 for the $120s.)

Perhaps someone with more experience can chime in with something obvious that I’ve completely overlooked.

1 Like

Assuming you upgraded grbl too, all of your offsets are reset. G0X-411 would move to WORK X-411. Were you entering G53 G0 or just G0?
How did you set zero once you got there? G92?

Edit: I just read your second post where you mentioned clearing offsets.
Any chance you had adjusted your steps/mm prior to upgrade? That gets wiped too.

1 Like

I just went back to grbl 0.9 and CM3 via this excellent set if instructions from Will:

There’s a few threads on how to go back to CM3 and grbl 0.9, but the above is by far the most succinct and understandable.

And… It fixed it. Now before I blame CM4, I’ll say that the first time I tried it with CM3, I swear it looked like is was back to the same incorrect spot. But then after switch laptops back and forth (I started this upgrade just because of getting a new laptop), somehow the error suddenly went away. I swear I have a talent for getting computers to give different outputs though receiving the same inputs. Most likely, I just did something different and didn’t realize it.

In short, thanks for all your help, problem solved. And if anyone needs to switch from CM4 back to CM3, use Will’s post above. There’s a few threads out there where the instructions are discussed, but the above one is the most understandable. thanks

Keep in mind that all your settings get wiped out in both directions - converting to 1.1 wipes out all your .9 settings, and converting from 1.1 to .9 wipes out the settings again - this includes all your $100-102 axis steps.