Can't open Carbide Motion

I updated Carbide Motion and it won’t start start. I get an error message “The program can’t start because MSVCP140.dll is missing from your computer.” I tried going to the Microsoft Download Center & install the Visual C but no luck. I get the same error. The error on the Carbide FAQ says MSVCP120 not 140 but what do I do now?

Please try the instructions for the other DLL — if they don’t work, repeat, but get the 2017 libraries instead.

You need the x86 version of the Visual C++ Redistributable for Visual Studio 2015

Download here Click here

2 Likes

Yup, looks like it worked. Thanks! Kinda pisses me off since Tech guy @ Carbide said, “Buy a new computer”.

The Link the website sends you to from the FAQ is the other version.

So, now Carbide Motion is working (on the old computer) & I have a new computer on the way!

Glad it worked out . .

I have been writing Windows software for 20+ years, server based mostly, and I don’t use anything that uses these run time libraries so as to avoid windows “DLL Hell”. It can drive you nuts.

3 Likes