Carbide 3d VFD Spindle Wont start

Hey guys, I have had the carbide 3d vfd spindle for about 6 months and have had 0 issues. I made a guitar last month with no issues. I started my project up and was ready to go and the spindle never fired up. The power button on the controller is on (side and front) everythings connected fine, but still wont start up. I can press the jog button and it runs while pressing the button so i know the connection is fine. is anyone else having this issue? I have an e-mail in to support and have to send them pictures of my board, but I figured this may be quicker to see if anyone is having similar issues. I have also tried to manually start the spindle through the software as well. Thanks for any tips in advance.

1 Like

Please let us know at

1 Like

what is the companies policy on returns? I cant be bothered with 3 weeks of self repair and diagnosis if machine isnt plug and play as advertised.

My Shapeoko Pro 5 has been rock solid since I got it.

No experience with the VFD spindles, but anyone who has a problem with one should contact and we will do our best to work through any issues, and if need be, warranty any defective parts until things are working as expected.

For the warranty see:

I believe there’s some specific language on the VFD spindle shop page as well.

Mine is a shapeoko pro. The vfd was working perfect a week ago and this week it just wont turn on. Connections are all fine and i can press the controller jog button and it turns on, but it wont stay on. Seems software related.

1 Like

My apologies, I’d thought the return policy was linked at the warranty page.


1 Like

this is out of hand dude… things break and things dont always run… to be fair, you should have checked the warranty before you ordered. We can all be civil without acting like we are owed something…


Im on an older machine with an actual issue, you havent even opened the box and are threatening with lawyers… just looks bad on you in my opinion. It’s frustrating I get it, but there are other ways to go about this. This thread was about an issue and you hijacked it making a scene. Contact Carbide 3D if you want to argue about a product you havent opened yet.

I’ve got an open support request for basically this same thing. Jog button works, machine won’t start the spindle. Worked fine on 4XXL for almost a year, just attached to Shapeoko 5 and it’s dead.


I did Hijack your thread. My Apologies.

1 Like

Mine is on the Shapeoko Pro XXL and I havent changed anything. It seems like once the new firmware update came out it messed it up. I wasn’t updated so i thought updating would help, but it didnt. It has power and everythings connected properly. To me its software related. Theres a miscommunication between the PC to the controller or from the controller to the Machine.

I get it man. I just think there’s other ways to go about this… Best of luck to you.

Does the light on the VFD push button look dimmer than it used to be?


Not that I can tell. But I guess theres always the possibility.

You can try opening the side of the VFD box that has the plug going to the SO5 and looking to see if there is a green lit LED. If the LED is not lit then you have a bad VFD control board. The BF824 PNP transistor is probably fried.

Please note that the VFD box needs to be plugged into the SO5 and the SO5 should be powered on.

1 Like

Will this ruin my warranty? Im on the shapeoko pro xxl and have sent the following images to support.

No, it would be illegal to void a warranty for opening the box.

Perfect. I will take a look as soon as possible and see if anything is fried. Thanks for your response!

I’ve had to use Carbide3D Support 2 times in the 6 months I’ve used the machine. Once for a warranty issue (router went bad) and the second was me with a modification to the Bit Runner (to run my dust collector). Turns out that it took the fuse out inside the Bit Runner. After replacing the fuse i’m back up and running. Also have it cycling my HF dust collector as well. Note, the Bit Runner was never used to run the dust collector. That was done through a timer relay. Works great.