Carbide Create 433 just released to unstable

Since I had to mention this in another thread:

It’s been in the work for a long while, but is finally at a point where we (well, @robgrz ) feels it can be shared for wider testing.

(FIX) Minimum RPM for speed/feed calculation
(FIX) Round RPM values
(FIX) Tweak feed/speed data


Just attempted to install & try out this latest beta, but getting an error at startup that tbb.dll is missing. Anyone else had/seen this problem?

for me the “show preview” no longer shows the material, just the tool paths… is that just me or do others have that as well?

Unfortunately your file crashes my machine (Windows 10, build 1703, so not a valid test since I’m not up-to-date) — hopefully someone who is willing to stay up-to-date with an OS will be able to look at your file presently.

I didn’t get that error — what version of Windows are you using?

Please check in at

Yes, it was a strange error as I would have thought the C++ Redistributable would have included it.
Anyway, after uninstalling, restarting my test system, accidentally installing CCv415, then installing CCv433 over v415, it now loads. Previously I had installed v433 in a different folder than ‘CarbideCreate’. So I’m not sure as to the why.

My test system also runs Windows 10 Fast Preview builds - which currently sits at v19030.1

same error here. I’ve always uninstalled prior and installed new.version. If you do that you are missing the TBB file. I installed 431, then the new unstable 433 version and it works.

1 Like

it’s running fine here with a few random crashes. I’m trying to figure out what is happening right before it crash.

I too am unable to launch 433 due to the same error on my windows 7 system.

“The procedure entry point GetSystemTimePreciseAsFileTime could not be located in the dynamic link library KERNEL23.dll”

Sorry for my quick draw on this issue… dug into the forum deeper and quickly solved my issue.
problem solved.

thanks and sorry.


1 Like

Build 433 ought not have this problem, but if it does, try Build 432 — contact us at for a link.

I had the same problem

I also install der the “unstable” on windows 7, but why is only “MDF” in the materials possible?
Is it for feed and speed important? Or is it to set over the router and the tools?
Why is only “MDF” possible? A problem with the unstable version?

Please help

I’m afraid that build 434 (the current unstable) only has MDF enabled.

Please try build 433 (now the stable release):

Will: does that make any difference except for previewing the project? I was checking the previous versions and there were no changes to the recommended F&S for the project based on the material selected. Are there any other use for the material selection?

To expand on what I was saying:

Build 434 (the current unstable) only has MDF enabled for selection as a material in Job Setup for automatic calculation of feeds and speeds.


The beta version works great:grinning:

Now CC440 is available for testing!

1 Like

And to expand on that, it has feeds and speeds for:

  • Acrylic
  • Aluminum
  • HDPE
  • MDF

for both the Nomad and Shapeoko