Carbide Create - 612 - Simulation

FYI: After clicking “Show Simulation”, I was unable to use left-mouse to tilt/rotate the simulation. The zoom also jumped from really small to really big.

The simulation initially loaded with toolpaths and rapids displayed, but the “Show Toolpath” and “Show Rapids” checkbox was unchecked.

I can confirm the second point and add a little detail:

It seems that, upon entry to the program, the value for “Show Toolpath” and “Show Rapids” are both TRUE even though the check boxes are not checked - as if the code to initialize the state of the checkboxes is missing. When you check those boxes for the first time (when they are not checked), they remain unchecked - and then become synched properly with the values.

I am not able to recreate the tilt and zoom issues

1 Like

I appreciate the feedback. We made some changes to the parts of the code that border on voodoo (the OpenGL display code) so I’m not shocked that we might have added a bug. If anyone can provide any additional details about how to trigger the problem, that would be helpful because we haven’t seen the mouse/zoom problem.

I suspect the Show Toolpath and Show Rapids will be easy to duplicate here. We’ll check it out tomorrow.

1 Like

I’m unable to really rotate the 3D toolpath preview — mostly it just drags to reposition.

Quick question- everybody with the dragging problem is on Windows, right?

I am.

Just downloaded and tested 612 on my Mac and the 3D preview seems fine there.

The Zoom, dragging and rotating, and toolpath viewing bugs are all showing up on my Macbook running High Sierra 10.13.6

Zoom, Drag, and Rotate work fine for me on Windows 10. (EDIT: I am now able to see the problem…see below)

Maybe there’s an issue with GPUs - Since your changes involved OpenGL - some GPUs may need to be set to use or not use it?

EDIT: Just encountered the issue on Win 10. I can only encounter it (so far) when opening a file. It does not matter if the file was created in v12 or a previous release - opening it leaves me in a state where I cannot flip in dimension…it just pans. I can rotate and I can zoom - but zooming is with a very large factor.

If I start from scratch after opening the program, everything works for me. However, if I start a new design AFTER having had the problem (by opening an existing file), the new file fails as well.

The problem does seem to be with reloading an existing file made in a previous version. If I start a new project from scratch all seems to work as it should

1 Like

Hii @Ed.E I created a file that worked fine in v12 (no problem)…saved it…closed and reopened v12 and loaded that same file and had the problem.

Good Morning Gary,
When I tried 612 I reloaded a project that I had started on a couple days ago using 611, that was a no-go. I’ll probably just reload 611 to finish it up today

Actually, it seems to be any file which is loaded.

Made a basic file:

it rotated fine in 3D Toolpath preview, then saved, closed, relaunched, loaded the just saved file — now the rotation doesn’t.

It’s the reload that does it. Think we’ll have a fix today.

5 Likes

Check out CC613 at https://carbide3d.com/carbidecreate/beta/

  • (FIX) Bad rotation on simulations.
  • (FIX) Initialize simulation options.
  • (FIX) Texture angle goes to 180 now.
  • (FIX) Select Circles command treated diameter as radius.
  • (FIX) Texture cutting depth not interpreted correctly.
  • (NEW) Updated Speed/feed library.
4 Likes

Those problems seem to be gone now (Rotation and checkboxes).

1 Like