Carbide Create Display issues

I attempted to open carbide create after the new Windows 10 patch, but the program does not display.

I tried uninstalling the program, deleting remnants from C:\Program Files (x86)\CarbideCreate, and reinstalled. It almost acts like it is in a second monitor, that is not connected.

This is still an issue with the latest. Guess fusion 360 is the only way to go. Sad really. Simple parts would be faster to make in carbide create.

@ApolloCrowe is there a slated fix for this?

We had one other case of this and it turned out to be a video card that wasn’t compatible in some way. He tried another video card in the same computer and it worked fine. If that’s the case here, there isn’t much we can do because the drawing code is deep within the Qt framework we use.

There is a new version of Qt coming out soon and it’s possible that will fix some of the problems with hardware compatibility.

What kind of PC do you have?
How old is it?
Laptop or Desktop?
Video card?
Is a newer video driver available?


1 Like

There may be a newer driver. The laptop is a Razor Blade quad-core Intel Core i7 4720HQ processor and NVIDIA GeForce GTX 970M graphics. It does have a QHD display. But overall the laptop is less then a year old.