Carbide Create doesnt open

Hey all,

I was one of the people who got in on the free year trial run of Carbide Create Pro and I guess today was the day that subscription ended for me.

I tried opening Carbide Create this morning and it wouldn’t open, I got a message that said “Carbide Create quit unexpectedly”. So I tried to reopen a few more times, but no luck. I deleted the program, and downloaded the regular free version of Carbide Create and got it to open once but got the message something about the subscription expired and a link but it disappeared and the application quit again. I havent been able to open it again.

Am I missing something here? I was able to use both the free version and the paid version at the same time for the past year, and now I cant use either. Carbide Motion opens just fine.

Any help would be greatly appreciated!
Happy Easter

Please remove the .ini file and license.txt file.

On Windows they would be in:

C:\Users\<YOUR USER DIRECTORY HERE>\AppData\Local\Carbide 3D\Carbide Create

If you have any further difficulties let us know at support@carbide3d.com and we’ll do our best to assist.

Thanks for the fast response Will! I forgot to mention in using a Mac. How do I access license files if the program wont boot up?

On a Mac the location is similar:

/Users/~/Library/Preferences/Carbide 3D/Carbide Create

(where ~ stands in for your user directory name)

You’re the man, seems to be in order now. Enjoy the rest of your weekend!

Hi Eric,
I had the same problem a few weeks ago and had to delete a couple of files and all is great,I am no computer expert so will not tell you which files to delete,but get hold of customer support and they will sort you out.I am on a Mac.What they first got me to do was open another account on the same computer and install CC this worked great as well.I have not installed the pro trial on the Mac again as I intend to get a new one.