Carbide Create Download not available?

Just pulled the trigger on a Shapeoko pro and was gonna download Carbide Create to get familiar with it.

When I go to the site to download it, the site seems to be broken for me, it gets stuck detecting version and I’m never able to download it. I’ve tried 4 different windows systems and a Linux system as well as multiple browsers ( Edge, Chrome, and FireFox) and all have the same issue.

Just curious if anyone else is experiencing this or if it’s unique to me.

I’m not getting that here — try going to:

and using the button there — I believe it should prompt for your e-mail address, store that you have entered that somehow, and then take you on to the download page.

Try a different browser or in private/incognito mode?

It finally worked, I just registered for the trial of carbide create pro and the link provided there seemed to work for the download.

On a separate note, I came across a post where you had posted an SVG of submarine dolphins… Are you a a submariner? I was on the 738 and 743.

Glad to hear you’re running!

No, I was Air Force, Skivvy-Nine.

This topic was automatically closed after 30 days. New replies are no longer allowed.