Carbide Create gone crazy with work area size

Yesterday I used Carbide Create 313 for the first time successfully with a simple job drilling precision-aligned holes in a box full of parts.

Today I wanted to set it up to do some slotting on a different face of these parts, and it’s totally screwing up my work area setting, I can’t get past that point. Has anyone experienced this? I’m on a Mac, macOS 10.12.6.

I launch Carbide create, and it comes up in Design mode. The work area displayed is a 1.000x2.750 (XxY) area inherited from my last project. This time I want 2 x 2-3/4 so I click on the Gear for Job Setup. I change the X from 1.000 to 2.000 by just editing the “1” to a “2”. (I do that because somehow I’ve seen that keying in the whole number sometimes ignores the decimal point.) The change isn’t reflected in the displayed area, so I click the Refresh looped arrow. At this point there’s something wrong. The display’s height didn’t change, but the width got super-wide. Assuming the Y display is correct at 2.75 inches, the by counting the grid lines the width is about 16 inches. The grid doesn’t seem to be the 1/8" that I had used before, it might be 5 mm. This is shown in the 1st screenshot.

I changed the Stock Thickness to 1.000 hoping that maybe changing another field might make the prior one “stick”. But no.

I click on Edit Background to change the grid to 1/8" … the grid spacing shows as 0.197 in, so it is indeed 1/2 cm originally. I change this to 0.125 by replacing the whole number, and clicked Reset View to try to get the change to display. At that point the area take on a more-square shape instead of skinny, and I think it might be reflecting the 2 x 2-3/4 area, but the grid spacing is extremely small. I think I counted 128 grid lines across the width. If so, and if the width is actually internally 2 inches, then the grid is displaying 1/64" instead of 1/8". This is the 2nd screenshot.

At this point I try to save the work area using Save As thinking maybe if I quit and reopen the layout the grid/shape will be better.

On Quit, Carbide Create crashes. The report box says, “Carbide Create quit unexpectedly.”

On relaunch the work area is the one I started with originally, inherited from an earlier project, not the one just worked on. When I do “Open” and specify the saved file (slot cut.c2d)it comes back as similar to last seen, the work area not all visible though, so I click Reset View. Then I switch to Design to check what it remembered, and it shows 16.000 x 16.000 inches instead of the 2.000 x 2.750 that I expect. This time I key them back in replacing the entire numbers but no change is observed. There isn’t a Refresh loop available, so I try Reset View, no change other than slight zoom change. This is the final screenshot.

I’m stuck! I tried reinstalling, I downloaded the most recent Beta, build 316, I restarted the machine, etc. It still comes up with the prior design’s work area (if that matters) so reinstalling doesn’t eliminate the “last state saved” file wherever that is.

Any ideas?

Try deleting the Carbide Create preferences file?

Where is that? I looked in the likely spots that I could think of, but didn’t find. Or, if you know the filename?

Mine does the same thing. My workaround is to delete the dimensions, put in 99 inches for width, 99 inches for height and then delete…and retype the height you want even if the dimension is unchanged, click apply. You will get an error message. Click “Okay” and click apply again. Another error box will pop up and click “Okay” again. Click apply and everything seems to reset, and hold that reset. I only have to do this when the program gets “squirrelly” (about every 20th time I open CC).


@BoscoBob thank you thank you! I was dead in the water. I don’t actually have an “apply” button so I tried “Ok” and got the two errors you described (‘machine not that big’) and then indeed it paid attention to the dimensions I entered. I think I’m back in business.