Carbide Create - Latest beta broke 4K support on Windows 10

So the latest beta broke 4K support on Windows 10. Not sure where to find the build number but it’s the May 4th release that I’m talking about. I tried the various compatibility options for Windows and the only one that kind of works but causes other issues is the “Run as 640x480” which is horrible to look at anyways. Technically the new version will run it’s very difficult to follow along with and everything is quite small to look (not easily visible in the attached image).

Couldn’t find a unified post to submit this error so I apologize if it is in the wrong area.

I had this issue with my monitor too, did it not give you an option to run as compatible with 1080p? mine did…?!

Hi Nick.

Thanks for assisting. Nope, I did not see any type of pop-ups at installation or first run. Under properties->compatibility (right-clicking the icon) there is only “Run in 640x480 screen resolution” along with other options like “Disable display scaling…” but none of that really seems to change it.

The best temporary answer I have found is to drop the resolution of my laptop down to 1920x1080 so that this program works normally. But it’s a little of a pain it is to change resolution, log out and then log back in just for this one program.

So weird… what monitor/gpu you using? Maybe there is an issue there…?

Hi Nick,

Thank you for any suggestions you might have. This is an Asus laptop with these specs and settings:

Asus Zenbook UX501vw
Windows 10 (latest update as of 6/4/2016)
Display settings of “250% (recommended)” for size of text
Resolution set to “3840x2160 (recommended)”

If I uninstall this version and return to the prior version of Carbide Create it works perfectly. The previous versions are honestly slightly blurry and are probably running at a fixed resolution up to HD (1920x1080) upscaled to 4K. That would explain the blurriness in those versions.

I just wanted to give some feedback to the developer(s) something has changed possibly with QT or possibly an upgraded a library is causing this new issue with Carbide Create.

I see now if I change the display settings to size fonts at 100% instead of 250% everything lines up correctly within CC. However, since most applications I utilize work, including the prior versions of CC, perhaps there is an answer for this. Also 100% is WAY tiny and not usable at this scale.

The same problem with Surface 4 Pro (i7), so it does not seem to be only some exotic hardware.

Hi - new to the Carbide 3d community. Purchased a S3XXL in Nov. I recently purchased a new Samsung laptop and seem to be having the same issue as the original post here. It’s running on Windows 10, but I don’t think that’s the issues since I was running CC on my previous laptop, which was also running on Windows 10. I’m thinking that it has something to do with the display settings. I’ve tried changing the settings as suggested in this thread and other, but nothing seems to work. Were you able to resolve your issue? Thanks for sharing.

The newer betas are supposed to be better about this sort of thing, and it seems to be getting some development effort t(which I’ve been asking for for a long while now and am very glad of, since I just got a new machine w/ a fabulous 2160x1440 display) — check in w/ w/ your system specifics and we’ll try to help.

Thanks WillAdams - I will send my system specifics to the support team. I’m sure it’s an easy fix.

1 Like