Carbide Create not loading DXF files

Just updated to beta 286; cannot import dxf files anymore. Beta 285 worked fine with the same dxf files.??? Also how do you delete a tool path…mac book pro. Ive tried delete and a combo of buttons with delete (fn,shift,control,option,command,etc)

If a DXF opened previously, it should still open.
Zoom out? maybe its off screen?

fn and delete to delete an object.

cntrl button will unlock a frozen Toolpath preview view.

Ok figured out how to delete tool paths…but still no Dxf file…zoomed WAY out…nothing

Try converting to an SVG or other DXF format with this free program:

how do i downgrade my CC to previous version…any thing new i design in fusion or upload any existing dxf files are not being opened in new CC…turning to be a great pain…

FWIW the latest version of Carbide Create v289 will now load DXF files created in Solidworks.

I’ll also add that I experienced delayed loading on several occasions with semi-dense dxf files in CC. I’d think it didn’t work, go off and try loading it in another program, then come back to find that it had succeeded at some point in the background. CC would be sluggish after that, though, so it still wasn’t technically “working.”

1 Like

Don’t mean to crash your topic, but the link to the userguide gave me a 404 Error.

I’m having trouble with the “freezing” you mentioned. There must be more than just pressing Ctrl. Could you give me a little more info on that?


They changed the site a bit, and the URLs don’t use .html at the end, instead try: