Carbide Create- Scale issue

I imported a DXF file into Carbide Create. Set scale at 1. Unit was 5.66 inches by 5.66 inches geometry with some holes and arms for the shape. Everything simulate fine, when loaded into Carbide Motion and started cutting it cut the holes the size they are supposed to, but shrank the entire size of the piece to be cut out by half. Wondering what is going on. Any help would be greatly appreciated, maybe even while I am snowed in for the next few days as I have a lot of parts to be cutting out for prototypes. Thanks!

What do you mean by cut the holes the right size?

My suggestion would be to bring in a 1" square from the app which made the .dxf, put it at 0,0, cut it w/ a follow path operation, then see what the code looks like in Carbide Motion.

Another way to say is, make sure your CAD output units match the CC input units. DXF files do not contain a units definition so 5.66 could mean 5.66 inches or mm or cm.


Hi Randy,

I checked all the output units in both my CAD app as well as my Carbide Create. In CC it does show inches as being selected in set up and in Design when I select the entire drawing and it tells me the max dimenions of the shape I want to cut out. Any other thoughts or suggestions? I just uninstalled and reinstalled all the software in case it was that, but no changes when I just went to test it again.



Brian, I’ll support the test that @WillAdams suggested. Export a known 1" square from your CAD program and check how large it is in CC. Your CAD program might be set to export in cm. In the CAD programs I’ve used, the DXF export units are set separately from the design units. A DXF exported as cm and imported as inches would show up as about 40% of the intended size.

I deal with that a lot with MeshCAM. I work in inches, and when I import DXF’s that were exported on a metric system in mm units, I need to scale the geometry by .0394 for it to be the proper size.



Hi Randy and Willadams,

I tried what you suggested and cut out a 1" block and it came out to be 10.64mm instead. Trying to see in ALIBRE if I have any way of changing the output units and I am coming up with nothing. In terms of scale what do you think would be the best course to use when I am using the Carbide Create? I tried adjust the scale based upon the ratio of 2.05 (1" equaled .423 inches cut by the machine.) The total cut seemed to be ok but the holes were way bigger than were drawn originally. Just wondering why the wholes would come out so much larger in ratio than the entire project? Seems odd.

I believe that you need to break this process down and describe it in excruciating detail for a very simple thing. I’d suggest a 2" square (to be cut w/ a profile), w/ a 1" round hole in the center (to be pocketed).

  • CAD — draw the part up — what tool was used
  • export — what file format was it exported to, using what settings
  • import — what CAM tool was it imported into, using what settings
  • CAM — what CAM settings were used for the pocket, what for the profile

I am drawing the part in Alibre Design 2012 as a sheet metal part. I then flatten it and turn in into a .DXF file. All available settings are set for inches. I opened it in AutoCad as well as Draftsight to make sure the part was properly scaled. It was. Everything still shows inches. I opened the DXF file (Autocad 2012 ASCII) in Carbide Create. Scale shows in inches the proper dimensions of the shape that is was drawn. I select all the proper tool paths and begin cutting. It is still not the proper size and looks like something is still telling it to be in a weird offset ratio when to comes to the file conversion. I only know how to use CARBIDE CREATE and have not tried anything else.

And now I just ran a few different tests to make sure I wasn’t going crazy. Tried the Meshcam and had the same results. Tried even making a 2" square in Carbide Create’s drafting program…still came out short by less than half. I think something is wrong with the machine or the program. Thoughts?

If you’re getting too short movements on the machine:

Thanks Will! I will try that tonight and see if that works.

That seems to have done the trick. Thanks Will!