Carbide Motion 351 - Mac USB hangs - Nomad 883 Pro [SOLVED]

I’m running 10.11.3 on a Mac Pro.

I was cutting the second on two parts, the first having run fine. When it got to a tool change, I changed to the tool and told CM to continue normally. CM hung leaving the spindle running in the middle of my stock/piece.

I rebooted the Nomad and the hang reoccurred. Killed and restarted CM. Still no motion. In all cases I could connect to the Nomad but I was unable to jog the machine or do any other actions.

Dropping back to 350 didn’t help either.

I rebooted my machine and I was able to connect to the Nomad and jog it. Resuming the job, it started cutting and then hung again, leaving the spindle running.

Rebooting the Mac tends to point a something going wrong with USB on the Mac end. I’ve proper grounds and neutrals but was not running with an isolator.

Strange that I could do so much machining and then this happens…

I’m going to investigate concurrent USB activity. The Mac Pro has a unique USB3 implementation.


I solved the hang. The Nomad is fine.

What happened in a USB3 backup drive hiccuped and disappeared from my machine. It would not appear as a USB3 device. Ironically, it would show up on another Mac (as a USB3 disk) and as USB2 on both machines.

That got me thinking… I rebooted and did a command-option-P-R firmware reset and everything was fine again. The disk showed up as USB2 and USB3 (there are different cables for each).

Macs having trouble with the Nomad 883 Pro have been reported recently and some of them were fixed in this manner as well. Something about the Nomad causes the Mac to get its USB screwed up. A firmware reset clears the problem and things are then negotiated properly.