Carbide motion 4 problem. HELP!

Downloaded the latest version of carbide motion 4 and now trying to perform a simple v-carve with .05 flat depth and as soon as i start running the file it slams into the wood and burys itself up to the chuck until i scramble to unplug everything. Using v carve desktop 10. Checked everything and its all good. Ran it again and same thing! Anyone else seen this?? I just finished running another file with no issues. The only other thing I did differently was that I set up all the files and modeled it in V carve on one computer saved it to USB then brought it down to another computer to run the file. 3 seperate toolpaths. 3 sepreate saved files. 1st v carve letters. 2nd inside profile on paw and top hook loop. 3rd outer profile to cut out. I do not have the bit setter

1 Like

Looks ok. Question, you said you ran prior work. Did you recalibrate z between the two jobs? Sounds like that might be the issue.
Or, just insure z switch is working correctly

I was looking around online and found where it says that you can not use GRBL v0.9 and CM 4. I have not flashed my PCB. Is flashing my PC be required in order to use version 4? I had just finished running a rather large file with no issues right before I tried to load this one when the router crashed into the wood.

1 Like

I reset the Z using the touch probe between jobs

Additionally whenever I select start program the Z raises to its maximum height and sound like it skips before you quick run then you click run and it dives into the board

Do you have an old machine? All recent machines are later version and CM 4 works fine,

1 Like

When you run your Z into the top of its range, it “thinks” it is higher than it is. That’s what causes the deep plunge. Your Z is set to start at 3.86" for some reason.

Change under “Material Setup”


what did you set as the safe retract height in the design tool?
it should be somewhere in the 0.05" to 0.1" range.

if it’s set to like 4" or even 2" you can get the behavior you describe

1 Like

I said all these positions to .2" then I ran the 1st of the 3 files for the V cut. The V cut went fine it did great got to the end of the file and told me I need a tool change I clicked continue it brought my gantry back to the left corner of the machine then I loaded the next file and went to start. When I started the gantry dropped down Lower than my L shaped alignment board around the corner of my waist board period from there the only option you are allowed in carbide motion is continue when you hit continue it smashes into the alignment board. The option was not even there to close carbide motion.

I have never had a single issue like this until I changed to version 4

So you fixed your original issue?

How’d you set zero with the new tool?

Yes the original issue is fixed. I should have elaborated. I did not have to change the tool, I just had to run the same program again. I am making a little gift tag that looks like an ornament so I run the V carve on one side flip the wood over, run the V carve on the other side, then i will change tools and start my profile cuts. I have 2 separate files for the profile cuts which will both use the same 8th inch end mill

So you ran the same program with the same zero, but started it outside your corner stop?

Outside the stop at the very back left corner of the machine. On the screen where you click load file or run file I clicked run file it dropped the spindle down real low then the only option was continue when you hit continue it stays at that low height and starts moving forward toward your work to begin running the file. I changed my Z gap above material to .8 and the that fixed it for me. Someone had suggested I set them all lower than that but then that did not give the machine clearance to move around freely. All working!.. for now :grin:


Right, your clearance height is needed for that exact reason.
Glad you sorted it out.


Thanks for all the help. This community is amazing!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.