Carbide Motion 428 / HDZ / Suckit

OK, still no reply from Support on this issue. I guess we are not a priority.

I did run a job using CM428 tonight and beside the issue of the presets and maximum work area, I’m pleased with the changes implemented in the new version. It really helps with the workflow.

The redundant menu pages were removed the load menu is on the run page and it shows the correct file name. The jog page has no longer the annoying “Done” button.

While I installed the tool change post-processor in Vectric, I did not upload multiple endmills for this job but I was prompted to install the proper endmill and to set the correct speed on the pop-up window. The spindle moved to my X0 Y0 position for tool change. At the end of the job, the spindle returned to the X0Y0 and a message to turn off the spindle is displayed in a pop-up window. Unfortunately, you cannot reset zero at that point unless I’m missing something in the workflow but it should work when I get my Bit Setter next week

Another new feature is the estimated time for the job and a countdown for the time remaining on the Run page. While it is not very accurate, it still provides an approximation of the time left but don’t use this to see if you are going to make it to an appointment.

All this to say that things are improving for Carbide Motion and the BitSetter will further improve the Shapeoko but the bugs identified need to be addressed soon…

1 Like

I wonder how many ears they sold with the HDZs? They went out of stock on the HDZs, so a lot of them… Guess is the programmer is on vacation.

In my test air cut yesterday, the only thing I saw was that at the end, I got message to change speed and then cut off spindle. Not that I care, It was one, then immediately the cut off.
I did notice that the time wasn’t nearly accurate, I had a 2 min test and with about 65% done, I was only 40 seconds in, and at 90% done, I still had a minute left. But overall was correct.

RE vetric - and this needs to be confirmed. I do not believe you need a tool change post processor. The req for the BitSetter is the tool is numbered in your CAM and you use the Carbide 3D post processor. CM handles the tool changes and implements its own workflow.

I have been having a think about this and think we have a solution. I need to test it.

Actually you do — if the post-processor isn’t enabled to allow tool changes, Vectric won’t allow you to output a single G-Code file with multiple tools.

@mbellon worked up a post-processor which has this feature enabled:

available here:

(you’ll need to rename it)

installation instructions:


Well, in fact you do need a post processor that supports tool changes but not the one I just tried and VCarve refuses to save the file with multiple geometry. @neilferreri @Luke

@luc.onthego Your tools are numbered with the same tool number. You just need to edit that.

1 Like

Thanks, I changed the numbers but one has to reopen each toolpath and select the bit then recalculate before saving. Just recalculating all will not change the number.

Added a video of sample run using 4 tool changes from aspire with the post processors uploaded by neilferreri
I’ve tried three of them and they all work. Just put in the my post processor folder and select one to use. The one provided by Vectric doesn’t allow multiple tools in one file. Oh, I apologize in advance for poor iPad video.

Tool Change

Thank you for the video John, I’m just curious if the speed was set the same on all bits because you were requested to set the speed only at the beginning during tool changes.

I think that is the speed I have in all of my tools, Dewalt min speed as the default. I know on this junk trial I didn’t change anything. I’ll go see what it does with a change

Well dang it, it picks up the first speed. And at the end, it displays that same speed… doesn’t change for each.

Yeah that is what I was wondering, I wonder if it is in the GCode or if CM does not see it.

I received a reply from Carbide Support:

Hello Luc,

Thank you for taking the time to point that out here. Development is aware of it and it will be addressed in a future build. Keep an eye out for it in the release notes.

Thank you

@luc.onthego - is the reply in reference to the crash w/ HDZ checked?

Yes, it had to do with the HDZ crashing when using the rapid position when the ears were installed.

I emailed support but you guys need to pull 428 with this crash or at least put a warning on the download page. I downloaded 428, lost the Z config, I had the suckit dust boot wings and it crashed on the left side of the gantry.

Support just told me not to use the left 3 far rapid positions, which I don’t like. You need to pull it or put a warning on the page. You new unsuspecting clients ordering the new probe is not going to be happy when it drives the gantry into left side. I was the unsuspecting client and I wasn’t too happy to find this error.

I am holding of using your new probe until you fix it, which I hope is soon. Kind of disappointed in your release and lack of seeing this in your testing. I use my Shapeoko all the time and you hope when releases are released they are seen some run time.

Please make it right,

And when do we expect to see a possible new release.

While I don’t disagree that there should be a warning on this but if you do not use the rapids on the right and your workpiece is within the safe work area, there is no reason to not use the probe, the two have no relationship.

1 Like

Anyone fancy trying this?

1 Like

I’ll try it tonight & post results.