Carbide Motion 5 crashes on loading a changed file with the same name

I wonder if anyone here have seen the same thing I have. I use Fusion 360 for my workflow. Here’s what I’m doing step by step and leads to a crash more times than I care to tolerate. It doesn’t happen every time, but happens enough to be really annoying.

The context - I’m trying to dial in some tooling holes to accept a 10 mm dowel pin without play. This needs to be super accurate. In Fusion 360, I figured out the parameters I needed and the feed speed and tool path to cut such a hole.

My setup: Fusion5 Tablet running Win 10, CM5, build 566

  1. In CM Load the nc file into Carbide Motion and run the program. This works every time.
  2. Measure the hole or try to fit the 10mm dowel pin into the hole. If the hole is too small, I increase the negative stock to leave by a few tenth.
  3. Re post the file, but over write the file name.
  4. In CM, load the nc file again. At this point, CM seems to try to parse the file, pauses, and then crashes. When it crashes, I have to re initialize and thus lose the previous reference, which is a bad thing because I’m trying to dial in a very precise fit. Here, I wonder if CM has a bug since it is parsing a file with the same name it is currently loaded with, but the content is different.

The work around I have is to re post the file under a different name. Which is not that bad, but I shouldn’t have to.

Have anyone with a Fusion 360 workflow seen this behavior. BTW, thanks to the Carbide support team; they tried very hard to help me but they don’t use Fusion 360 and can’t replicate my problem.

Why not update the filename each time you write it out?

1 Like

Read the post. I explained it.

BTW, I’m a retired software engineer. Most likely the devs are using Visual Studio and .NET framework with C#. My guess is that the File Handle object might not be renewed since the name is the same; thus when reading it will cause problems.

I have been using the v7 since the first beta. I was renaming each iteration of the file name until I realized I could disable toolpaths and save and they were still there when reopened the file. Sometimes I just need to repeat a certain toolpath only and dont want to waste time recutting toolpaths that are good.

In the before time of the v6 and below I have a cnc_router folder and then a project_templates folder and then individual folders for projects. Some of my projects are really multiple projects so I just put all the c2d files in the same project folder. It makes file management easier. I used to have a folder inside the project folder for gcode but that is no longer necessary any more with v7.

More direct to your question on my HP Laptop I often reload the modified file name, same name, and have never got a crash. My only anomaly is when I turn off my Shapeoko with the usb plug still plugged into my laptop it crashes my laptop with the blue screen of death. The machine creates a core and then reboots. It only takes a few minutes to do this and I try never to leave other applications open with unsaved work as a rule and not because of this problem. I used to work with people that would have 50-60 browser windows open and seemed like every application they have but I like to keep things simple.

I have not seen anyone else complain about this issue so maybe it is localized to your environment. There are so many variations on OS, hardware, drivers and so on it is impossible to cover every situation.

Perhaps you could look at the logs to see if you got some hint to the cause for the crash like out of memory or a bad bit of ram or something like that.

566 crashes often when I load a new file, regardless of file name. It does not lose my zeros, though, so I reinitialize and continue on. Since I use Vectric this may be a different issue, but I hope it helps you solve it. Mine parses to about 10% and shuts down. I tried gsender for that reason but the macros for tool changes don’t feel good, although they work, but I came back to CM 566

May I ask what hardware you are using? Also, if you are using a cloud drive or local hard drive where you are reading files from. My crashes while parsing too - my guess is it has to do with the process of reading the file.

If you have a particular file that can trigger a crash, send it to us. If we can duplicate it, we can fix it.

1 Like

I think for the sake of preserving the highest precision as possible, I would be saving each file as a new name every time. I feel like this is a Windows bug more than a CM bug, and I think you are probably hitting on the root cause with your prediction.
It does make me wonder if this same workflow would cause a crash on a Mac OS version of CM.
I haven’t needed Fusion 360 for any of my projects so far, but I may give it a try and see if I can cause a crash in Mac OS.

If I may suggest, Carbide3D should implement an exception trap and send the stack trace at the time of crash back to your dev team for analysis. This makes sense since you can’t possibly replicate all workflows out there for the sake of fixing bugs. BTW, I started seeing the crash since the recent update to provide a preview - i.e. parsing the file.

Not sure if you were asking me but I use a Microsoft surface pro 3 with a SO pro XXL
The files run fine after I turn the SO off, reconnect and initialize
These are tool change files generated in Aspire. The latest was also a tiling project. Crashed while loading T2. The only problem is the crash but it is fully functional afterward, and the project cut perfect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.