Carbide Motion 618 problems

I just upgraded to Carbide Motion 618 for my HDM and I am hitting two problems.

  1. Every time I launch carbide motion it requires me to go through new machine set-up.
  2. If I run a file, it will start the spindle at a very low speed and a pop-up asks me to set the speed.

Any ideas?

If it helps, here is the debug info from Carbide Motion

Machine: Shapeoko
GRBL Version: 1.1f

Carbide Motion 618
Machine Controller State: INIT
Grbl Cycle: Idle

“bitRunnerEnabled”: false,
“bitSetterEnabled”: true,
“bitSetterX”: -45.0,
“bitSetterY”: -515.0,
“bitZeroType”: 2,
“connection”: 1,
“lastConfigSent”: 7,
“lastProbeIndex”: 0,
“lastSizeOption”: 0,
“odometer”: [
“cleared”: false,
“minutes”: 2.493516666666663,
“startDate”: “2023-08-25”,
“travelX”: 2562.676025390625,
“travelY”: 2862.2419452667236,
“travelZ”: 1549.4899916648865
“showCarbideRouterRpm”: true,
“spindleType”: 0,
“travelX”: -685.0,
“travelY”: -535.0,
“travelZ”: -140.0,
“version”: 0,
“workOffsetX”: 371.79400634765625,
“workOffsetY”: 371.6440124511719,
“workOffsetZ”: 41.89999896240235

0 = 10, Step pulse, microseconds
1 = 255, Step idle delay, milliseconds
2 = 0, Step port invert, mask
3 = 0, Direction port invert, mask
4 = 0, Step enable invert, boolean
5 = 1, Limit pins invert, boolean
6 = 0, Probe pin invert, boolean
10 = 255, Status report, mask
11 = 0.02, Junction deviation, millimeters
12 = 0.002, Arc tolerance, millimeters
13 = 0, Report inches, boolean
20 = 0, Soft limits, boolean
21 = 0, Hard limits, boolean
22 = 1, Homing cycle, boolean
23 = 0, Homing dir invert, mask
24 = 100, Homing feed, mm/min
25 = 3000, Homing seek, mm/min
26 = 25, Homing debounce, milliseconds
27 = 3, Homing pull-off, millimeters
30 = 24000, Max spindle speed, RPM
31 = 0, Min spindle speed, RPM
32 = 0, Laser mode, boolean
100 = 160, X steps/mm
101 = 160, Y steps/mm
102 = 160, Z steps/mm
110 = 5000, X Max rate, mm/min
111 = 5000, Y Max rate, mm/min
112 = 5000, Z Max rate, mm/min
120 = 500, X Acceleration, mm/sec^2
121 = 500, Y Acceleration, mm/sec^2
122 = 500, Z Acceleration, mm/sec^2
130 = 685, X Max travel, millimeters
131 = 535, Y Max travel, millimeters
132 = 145, Z Max travel, millimeters


Travel (km) 0.00, 0.00, 0.00, 0.04 Hours since 2023-08-25

Queue Empty

1 Like

I suspect the problem is something with this line:

I have no idea how to change it or what to change it to.

1 Like

I don’t mean to hijack this thread, but I am also having major issues with this update. My spindle actually starts to spin, but as soon as it cuts into something, the machine gets “stuck”. It stutters and doesn’t move anymore. Nothing else has changed for me - just upgrading from 568 to 618.

Let us know about this at

I sent emails covering all of this.

The C3D website says support till 3:00 PM on Saturdays but I have not been able to reach anyone. I tried asking for a call back just before 9:00 AM and have not heard back Did you see the emails I sent with the screenshots?

I am stuck an need to get moving again.

There are only a few people who have access to/experience with HDMs, and thus far, they’ve “just worked” so not confident of suggesting anything other than reverting to 582:


Mac OS:

If you haven’t tried that, I’d suggest trying it — if you have, and haven’t let us know what happened please do.


I did capture what should be the correct settings for an HDM at:

please check if they match or no.

I did go back to 582 and that seemed to work.

I compared the settings you provided and the only difference was number 21. Your reference said it should be 1 and the debug tab on 618 said it is set to 0.

I noticed that Carbide Motion 582 does not have the debug tab. Do you know what file has all these settings? I would like to look up what they are for 582

One more question: Is there a way to see the actual spindle speed during a cut?

BTW: I am on windows 11

I went back to 582 and that didn’t fix the problem for me. I think we need something that sends the right settings to the VFD. I’m sure that will do the trick.

I went into my Laptop at the Machine and found the file location for 618 and deleted it.
Then put in a USB that had a copy of 582 from my desktop and installed. I did note that in the settings, it had a dropdown box for the Type of router being used. I didn’t see that on 618. Glad to say that fixed all of my problems.

This topic was automatically closed after 30 days. New replies are no longer allowed.