Carbide motion arrows in jog position not working

I am trying to set up my bitsetter. When I am on the jog/page, the arrow keys do not work. I have a touch screen computer and those arrows do not work either, neither to d arrow keys on my computer work to move the router. They keys work in other programs, just not this one.

The router moves when I use rapid positioning, but other than that, I cannot get it to move.

I am using build 513.

Any help would be greatly appreciated.

Some touch screens have been problematic — please try using a trackpad or connecting a mouse — an active stylus usually works.

I have used all options. I am stymied!

Does the program not work with a mouse?

Please let us know the specifics of your configuration at support@carbide3d.com and we’ll do our best to work through this with you.

no, the program does not work with the mouse or the physical arrow keys on my keyboard.

Please contact us with the specifics of your system at support@carbide3d.com — do you have some other computer you could try/test?

no I do not. My arrow keys work on other programs with this computer if that was the question.

Please note that the keyboard shortcuts for Jogging only work when that pane is active and has focus. If they still don’t work then, please let us know step-by-step: what you did, what you expected, what actually happened and we’ll do our best to sort it out with you.

I am not sure what is meant by has focus, but I am in the window that I would job the machine, otherwise I don’t need the arrow keys.
I had a laser attached to the router. I removed the router ( I used Lightburn as the software for that) then when I went back to use the CNC router, the arrows no longer worked. No sure if that is just a coincidence or one actually affected the other.

I di nothing else to the machine that would cause this to happen. I have noticed that when the bitsetter checked the z axis, it touches the probe then on the second touch, the increments at which the router is lowered it extremely slow.

Please try re-sending the machine configuration.

Did you re-flash when using Lightburn? If so, you should re-flash back to an installation of Grbl which has the Carbide 3D settings — contact us at support@carbide3d.com for the specifics.

I do not remember if I re-flashed, but that does sound familiar, maybe. I will use the link you provided to get the instructions to re-flash back.

The jog buttons will not work if you have a job queued/paused.

1 Like

Make sure you use the lightburn macro “Use CNC” after you finish using the laser…that will put the key settings back to what the CNC expects.

These are my macros as I have them in LightBurn:

Use CNC
$10=255
$32=0
G10 L2 P1 X0 Y0

Use Laser
$10=0
$32=1
G10 L2 P1 X-845 Y-850

I’m not saying that this is the problem, by the way - it’s just necessary and a best practice.