Carbide Motion Crash - Unable to Connect to Nomad [RESOLVED]

Please help.

Fired up the Nomad, homed, measured the tool, CM crashed and I cannot get it reconnected.

Older Software



This happened to me recently - on a Mac. If you’re on a Mac, please reboot and immediately after the bong, hold down command-option-P-R (you’ll need two hand unless you’re build radically different than most humans). There will be a delay and another bong. Release. The machine will not finish rebooting.

Did that clear the issue?

When this happened to me, the USB “gummed up”. A reboot didn’t clear it but the super reset did. Apparently there are parameters that get stored that can cause problems. I’m not 100% sure yet but the issue may occur more easily when USB 2 and 3 designed are mixed.


Did not work. Still doesn’t read it. I opened Simplify3D to view all my USB ports…it still sees my 2 printers, but no Nomad. It always showed up in that list too. I’m beyond frustrated right now.

I just tried resetting the SMC…still nodda

It always showed up in that list too. I’m beyond frustrated right now

I hear you… Sorry this is happening.

Try power cycling the Nomad, with a 5 second delay in the middle of the sequence?


Already tried it. I’ve exhausted my bag of tricks short of dropping it in the bathtub and hoping for the best…

One more thing to suggest - try a different cable, preferably one that is shorter than the one you’ve used in the past.

Did you try different UBS ports on your machine?

Running out of things to suggest… :confounded:


Tried gold plated, insulated, USB hub ports, physical ports…it’s a 70lbs paperweight right now.

I can’t even access the port to reset GRBL. This is F’d…

Still not connecting…

Things tried: reboot, shut down, NVRam reset, SMC reset on a 2015 MBPr 15" running 10.11.2 (There’s a 10.11.3 update, praying that works in some way)

4 different USB cables, all powered HUB ports, all physical ports.

Across the board the Nomad isn’t showing up as a connected device: Terminal, About this Mac, Simplify3D device list. As far as I can tell the onboard USB controller in my Nomad is dead stick. Today marks the Fourth time I’ve turned it on.

Anyone with any suggestions? Still waiting on support to email back.

“He’s dead Jim” :scream:

If I think of anything I’ll let you know… otherwise it is wait for all knowing Jorge/Apollo.

(There’s a 10.11.3 update, praying that works in some way)

Didn’t seem to make any difference when I had issues. YMMV.


The Nomad is effectively an Arduino. Could the processor have lost it’s firmware? If so, it would behave like this.

I’ve seen a few postings about reflashing the firmware. Perhaps that is something to try?


Another possibility is the EEPROM for storing settings us corrupt. Install the Arduino IDE, run a sketch which clears it, then re-flash Grbl and update your settings if need be.

1 Like

One more thing, you need to turn off the Nomad AND uplug the USB from the computer to get the Arduino to power on reset. The Nomad’s Arduino will get power from the USB port even if the Nomad is turned off. To do a full restart of the Nomad the USB needs to be unplugged and the Nomad needs to be powered off.

1 Like

There is a knowledgebase article on this:

1 Like

All of this info would be helpful if I could view or connect to the device. It’s dead stick. I’ll have a new board on tuesday. Thank you all for the help tho!


ISSUE RESOVLED: Main board failure.

You guys rock, thank you for the quick turn around.